Jump to content


Photo

Cannot perform backup using TMG 8


  • Please log in to reply
55 replies to this topic

#21 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 18 January 2012 - 11:28 AM

Hi Jim
Should have added that I have no problems backing up TMG7 although I still get the missing external exhibits message when it completes.

And the validate file integrity steps listed above were all made in TMG8.

Thanks for your continued support...

#22 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 18 January 2012 - 11:47 AM

Hi Jim

In the TMG8 restore log I found the following, it is referring to the 26 missing external exhibits reported when I backup TMG7. Yes it only specifies 4 exhibits of PDF format. Sorry to bombard you with all this info. But hoping it will help you in someway.

* Exhibits *
17-01-12, 14:14:01 **************
17-01-12, 14:14:01 *.
17-01-12, 14:14:01 *(+) Use the default path for external exhibits
17-01-12, 14:14:01 *Restore exhibits to this folder :C:UsersDavidDocumentsThe Master Genealogist v8Exhibits
17-01-12, 14:14:01 >Found 26 exhibits with links to external files.
17-01-12, 14:14:01 > (not found in SQZ) updated from "c:UsersDavidPicturesCensus ImagesJames Davies 1851.pdf" to "C:UsersDavidDocumentsThe Master Genealogist v8ExhibitsJames Davies 1851.pdf"
17-01-12, 14:14:01 > (not found in SQZ) updated from "c:UsersDavidPicturesCensus ImagesSamuel Short 1871.pdf" to "C:UsersDavidDocumentsThe Master Genealogist v8ExhibitsSamuel Short 1871.pdf"
17-01-12, 14:14:01 > (not found in SQZ) updated from "c:UsersDavidPicturesCensus ImagesSamuel 1881.pdf" to "C:UsersDavidDocumentsThe Master Genealogist v8ExhibitsSamuel 1881.pdf"
17-01-12, 14:14:01 > (not found in SQZ) updated from "c:UsersDavidPicturesCensus ImagesHannah Short 1891.pdf" to "C:UsersDavidDocumentsThe Master Genealogist v8ExhibitsHannah Short 1891.pdf"
17-01-12, 14:14:01 Restore finished

#23 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 18 January 2012 - 12:00 PM

Hi Jim

Here's a snapshot of the TMG7 list of external exhibits log - you can see it's unreadable. And below is a snapshot of the TMG8 backup log showing that it does not proceed past the list of Missed Exihibits.

ÿØÿá øExif II*     b   j (        r i‡  ¢ ,  ,   ÿ  €  ÿ  €  ÿ     0220‘     0100           Ì ÿÛ „   222$$$26000066666666666666666666666666666666666666666666 ((0060(066666666666666666666666666666666666666666666666666ÿÄ¢  
  
  } !1AQa"q2‘¡#B±ÁRÑð$3br‚
%&'()*456789:CDEFGHIJSTUVWXYZcdefghijstuvwxyzƒ„…†‡ˆ‰Š’“”•–—˜™š¢£¤¥¦§¨©ª²³´µ¶·¸¹ºÂÃÄÅÆÇÈÉÊÒÓÔÕÖ×ØÙÚáâãäåæçèéêñòóôõö÷øùú  w !1AQaq"2B‘¡±Á #3RðbrÑ
$4á%ñ&'()*56789:CDEFGHIJSTUVWXYZcdefghijstuvwxyz‚ƒ„…†‡ˆ‰Š’“”•–—˜™š¢£¤¥¦§¨©ª²³´µ¶·¸¹ºÂÃÄÅÆÇÈÉÊÒÓÔÕÖ×ØÙÚâãäåæçèéêòóôõö÷øùúÿÀ Ì" ÿÚ   ? ¼0™¿Èþu.p8þ/þµUF.Øè3ÿ ׫‘¦Nk˜ÜX×·¯SôÏøÕµ„c&œ±í?•1¤,qÐR ýüO¯5]¤¸çõÇøv§7?…F¸=…P‡9#oª´n=²Ó½ZV¹úÿ õ¿
̹“µy$ôü{þŸ"†–ó&P>§üÿ lŠ§ooåàž[¹ïÍ]#¥Å-'Z n(4êkPÒŸHih(¢œ(¦…§
( ¤¥4™ Å.):€¶Šu7 t¦nÍ+R(ãŠZ@is@ GZZ1 ¸¨‹‘Iæ ›ŠƒÌ4ß0ЊLÕ4Ó|Ò(×JkÚªùÆ8БKU ÍGžÔq@)Hæ©yì(7


TMG8 Backup Log
18-01-2012, 19:37:34 * TMG v 8.00.0000 ********************************************************************************
18-01-2012, 19:37:34 >OS - Windows 6.01, 6
18-01-2012, 19:37:34 >Backup file - C:UsersDavidDocumentsThe Master Genealogist v8BackupsPotter_Family_Tree_Master 2012-01-18 19-37-29.sqz
*********************
* Missed Exhibits *

#24 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 18 January 2012 - 12:02 PM

Hi Jim

I'll stop there and give you a chance to digest what I have sent to you.

Many thanks

Regards David

#25 nbradley

nbradley

    Neil Bradley

  • User Group Coordinators
  • 147 posts
  • Gender:Male
  • Location:Perth, Western Australia

Posted 18 January 2012 - 04:01 PM

David,

Have you tried backing up without external exhibits.

Edited by nbradley, 18 January 2012 - 04:03 PM.

Cheers, Neil
Western Australia

#26 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 19 January 2012 - 03:46 AM

Hi Neil

Thanks for the suggestion, but that's part of the problem as i cannot uncheck the external exhibit backup flag?

Regards

David

#27 DaHen

DaHen
  • Members
  • 6 posts
  • Gender:Male
  • Location:Massachusetts

Posted 19 January 2012 - 04:06 AM

Thanks for the suggestion, but that's part of the problem as i cannot uncheck the external exhibit backup flag?


Same here, its grayed out........

#28 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 20 January 2012 - 08:04 AM

Hi Supporters

I installed 8.01 today, hoping this might fix my problem with the backup showing Invalid Path or File Name. Unfortunately, it did not. I still receive the same error message.

Furthermore, I still cannot uncheck the Project Data - External Exhibits Flag when performing the Backup.

And running the File Validation Routine makes no difference.

Please assist as I am unable to use this program until I can reliably make a backup!

Regards

David

#29 DaHen

DaHen
  • Members
  • 6 posts
  • Gender:Male
  • Location:Massachusetts

Posted 20 January 2012 - 08:35 AM

Same here. No change.

Looks like its time to move on. TMG was good when it worked.

#30 Robert Jacobs

Robert Jacobs
  • Senior Members
  • 308 posts
  • Gender:Male
  • Location:Ellensburg, WA, U.S.A.
  • Interests:Computers, hiking, formal shooting competition

Posted 20 January 2012 - 09:13 AM

Try checking "save as new configuration" on the opening backup screen before you reach the exhibits check box.

There is a known problem with backing up external exhibits in some cases; the large fact is that TMG is working for almost everyone.


Robert

#31 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 20 January 2012 - 12:27 PM

Hi Robert, I have already tried that possibility and it doesn't work, but thanks for the suggestion. I can understand the reaction from DaHen but I'll be frank here. I want this fixed. I asked for this to be fixed under TMG7 but the response from Phil (who has taken over from Dorothy Turner it would seem) was less then acceptable in that I had to wait for TMG8. I was told the problem in TMG7 was understood by technical development and would be solved in TMG8. Clearly not!

I want to continue with TMG8 as it suits my needs. But I need this fixed, and remarks from Phil only this week, in a response to my technical support request - stating I should pursue the problem with the TMG Forum is just not good enough.

I have a great deal of database experience myself, but not with Visual Fox Pro and I am fairly confident there is a 'work around' to this problem - a simple Fox Pro script to reset certain flags or clear offending data areas is surely possible. I just need someone in development to help with this.

Can we please get this on the radar and sorted now, even it involves a private patch for me alone.

Regards

David Potter

#32 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 22 January 2012 - 08:29 AM

Hi Robert, apologies for venting my frustration on your post. It was not my intention to upset you in anyway. I just want support to recognise this problem and help me to solve it as they said they would when I first reported it months ago with TMG7.

I want to continue to use TMG as I have invested a lot of time in it by the way of custom flags and the like.

Would someone from support please pick this up and work with me to solve it. I can't be the only person using TMG8 with this problem so it would make sense to have it solved for the wider benefit of those upgrading from 7 to 8.

Many thanks..

David

#33 Robert Jacobs

Robert Jacobs
  • Senior Members
  • 308 posts
  • Gender:Male
  • Location:Ellensburg, WA, U.S.A.
  • Interests:Computers, hiking, formal shooting competition

Posted 22 January 2012 - 09:13 AM

Dear David,

I'm not troubled at all by your response. Nothing is more frustrating than to have the real work interrupted by equipment or software problems.

Do I understand correctly that TMG7 won't allow you to back up without the exhibits?

Robert

#34 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 23 January 2012 - 02:17 AM

Hi Robert - thanks for understanding.
The problem is I cannot backup in TMG! I can backup in TMG7 but it continually reports missing external exhibits when it displays the backup completion dialogue. I think the problem with TMG8 it is due to a problem I first reported in TMG7 and to do with External Exhibits that TMG believes is missing, but I don't have any so it is stuck in this perception of missing exhibits. If you would kindly follow the threads of this post you will see in more detail what I think is wrong.

When backing up in either version - I cannot uncheck the Project Data - External Exhibits flag, if we could somehow fix that - I could then create a fresh backup without external exhibits which the program believes is missing, to be restored into TMG8 and hopefully resolve the backup problem in TMG8.

Regards

David

#35 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 23 January 2012 - 02:19 AM

Hi Robert

Slight typo error on the first line of my last post.

The problem is I cannot backup in TMG8. I can backup in TMG7 but it continually...



Regards

David

#36 Robert Jacobs

Robert Jacobs
  • Senior Members
  • 308 posts
  • Gender:Male
  • Location:Ellensburg, WA, U.S.A.
  • Interests:Computers, hiking, formal shooting competition

Posted 23 January 2012 - 06:59 AM

Dear David,

Unfortunately I have already uninstalled my copy of John Cardinal's TMG Utility in anticipation of the new version which will work with TMG8. If I recollect correctly, TMG Utility has several functions for exhibits, including, I think, a way of exporting internal exhibits. You could run the present TMG Utility against your version 7 files.

There is also a program called Pathwiz (I've never seen it) which also is supposed to deal with external exhibits. There may be helpful functions which at least allow you to track down erroneous entries.

Are all your external exhibits reported as missing? Are your external exhibits in one directory or in multiple directories? Are you able to look at them outside TMG -- e.g., with Windows Photo Viewer, Adobe reader (for the PDFs), etc.?

R.

Edited by Robert Jacobs, 23 January 2012 - 07:11 AM.


#37 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 23 January 2012 - 07:38 AM

Hi Robert

Thanks for the continued support...

I do have the TMG7 version of this utility and will investigate what capabilities it has for identifying issues with external exhibits. Will advise how I get on. Failing that I will try to track down pathwiz and see what that can do.

Re your last point. I no longer have any external exhibits, all my exhibits were re-input as internal exhibits within TMG7. But it is possible there was some issues in this conversion process when I lost my last laptop (disk crashed) and when I restored TMG7 to a new laptop it suddenly started to report missing external exhibits when completing the TMG7 backup. And the VFI report still gives unreadable text in the Missing Exhibits Section so I could not follow what it thought was missing as I couldn't read it. This was all reported to Phil in support, and he even looked into my TMG7 file and gave an explanation as to what had gone wrong. Followed by assurances it will be solved in TMG8. Problem with TMG8 is it doesn't even complete the Backup so I'm stuck completely until this is solved. Perhaps you could ask Phil can he backtrack to that incident and recall the technical reasons behind the problem which might take us somewhere. Just a thought.

Will be back later with the results of the utility test to see what it can do.

Many thanks

David

#38 Robert Jacobs

Robert Jacobs
  • Senior Members
  • 308 posts
  • Gender:Male
  • Location:Ellensburg, WA, U.S.A.
  • Interests:Computers, hiking, formal shooting competition

Posted 23 January 2012 - 08:38 AM

I have no special relationship with WG or it's tech support. I'm just a user like yourself, and so my appeals to Phil will surely have no greater weight than yours.

I would guess that the reason the external exhibits check box in the backup wizard is grayed out because there are no external exhibits. I opened the sanmple project, which also has no external exhibits and found that box grayed out in the backup wizard. So that's probably not the source of your problem.

I'd try to establish a new, clean backup directory somewhere on the machine; then carefully point the backup preferences to that new directory and try the backup again, being sure that the backup wizard also points to the new directory.

If that doesn't work, I'd be tempted to export all the exhibits in v7, using TMG utility, and the remove the ones that started out as PDFs. Then try the backup, restore into v8 and see if it's now OK. If not, try removing the rest of the internal exhibits and repeat.


Robert

#39 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 23 January 2012 - 08:41 AM

Hi Robert

Here is the result of the TMG7 utility for Exhibits (see below). You will see it does not find any External Exhibits or problems with the Paths to 261 Internal Exhibits. I have also looked into the Pathwiz but it a) it does not describe any abilities in the way to fix things, and B) it costs $25 and not sure if it would help at all.

I noticed the TMG7 utility allows Internal Exhibits to be exported as External Exhibits. But I'm not sure I want to do this as I would have to delete 261 Internal Exhibits so as to reference the new created External Exhibits and lot of time required to do this which sort of defeats the benefits behind using the Internal method. But please let me know if you have other ideas in this area that might solve the underlying problem.

TMG Utility v7.1.2
Copyright © 1999-2011 by John Cardinal. All Rights Reserved. Do not redistribute.
Function=Verify Exhibit Paths
Project=Potter_Family_Tree_Master_ (C:UsersDavidDocumentsThe Master Genealogist v7ProjectsPotter_Family_Tree_Master_)
Dataset=Tmg_full_24102009 imported on 27/10/2009 08:14:10
Log Only=True
Started at 16:32:32
Options:
Missing Only: Unchecked
Create Folder Report: Unchecked
TMG Exhibit Folder: C:UsersDavidDocumentsThe Master Genealogist v7Exhibits

Finished at 16:32:32
Elapsed Time=0 seconds
Exhibits=261
External Exhibits=0
External Exhibits Found=0
External Exhibits Missing=0


Kind Regards

David

#40 Mule2303

Mule2303
  • Members
  • 37 posts
  • Gender:Male

Posted 23 January 2012 - 08:45 AM

Hi Robert

You just beat me to it with your post. You can see I was not keen to export internals as externals but let's pursue your thoughts here. By the way I have aready tried the new folder approach, created a folder on my desktop and made the neccessary setup adjustments and it did not solve the problem.

Back soon with some questions of the use of the utility to export internals as externals

Regards

David




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users