Jump to content


Photo

Strange Behavior in Journal Report for TMG v8.01


  • Please log in to reply
9 replies to this topic

#1 Joe LaPointe

Joe LaPointe
  • Members
  • 15 posts
  • Gender:Male
  • Location:Sunnyvale, CA

Posted 25 January 2012 - 03:35 PM

The Journal Report for TMG v8.01 seems to have issues with spouse's narrative and extra line feeds. I need to describe a family with three generation in order to explain the issue. Please bear with me.

Generation 1: Innocent Audet, Spouse Vincende Roy, Child Nicolas
Generation 2: Nicolas Audet, Spouse Madeleine Deprés, 11 children

Journal Report for Nicolas Audet including spousal narrative
Narative for Nicolas
Madeleine Deprés
Blank Line
Narrative for Madeleine Deprés
Blank Line
List of Children

Note that there is no blank line between the narrative for Nicolas and the line with just her name. Why a single line with her name?

Journal Report for Innocent Audet with spousal narrative
Narrative for Innocent
Narrative for Vincende Roy
Blank Line
Journal Report for Nicolas as above.

Note that there is no blank line nor a single line with Vincende Roy's name between the narrative for Innocent and Vincende as in the example above.

Has anyone observed this behavior? Is there a fix or is this a bug that should be reported?

Thanks,

Joe LaPointe

#2 SmithOJ

SmithOJ
  • Members
  • 4 posts

Posted 26 January 2012 - 04:43 AM

Joe
I get the same behavior and had already posted it here under title "Possible Bug in Journal Narrative Report"

I could not figure out how to link that to this reply so I just copied what I had posted before here.

This bug has really made all my Journal Narrative Reports quite difficult to read due to the extra carraige returns.
Oliver



I seem to be getting some extra carriage returns in my Journal Narrative Descendants reports in V8 vs V7 and I am not sure if it is me or a possible bug.

I have tracked it down to an extra carriage return is inserted when there is information about a child’s spouse and that couple has no children so they are not carried forward in the next generation. However if I have a note for that child that prints in the report then no extra carriage return is added. So to better illustrate:

In the family below there is an extra carriage return before Samuel Oberholtzer's information but there is not one before Casper Eberly's. Notice I do not have a note tag for Bertha whereas I do have one for Anna.

I can reproduce this for any number of families.


24. Mary F. Charles (Christian, John) was born on 25 Apr 1856, PA. She married Christian Newcomer Forrey, on 24 Oct 1878.
Christian Newcomer Forrey was born on 17 Dec 1853. He died on 4 Mar 1939, at age 85.
Children of Mary F. Charles and Christian Newcomer Forrey were as follows:
i. Bertha Forrey She married Samuel Burkholder Oberholtzer.

Samuel Burkholder Oberholtzer was born on 5 Aug 1878. Samuel was enumerated as a Farmer in the 1920 Census in Warwick Twp., Lancaster Co., PA.
ii. Anna C. Forrey was born on 19 Sep 1895. She married Casper Schmuck Eberly, on 29 Mar 1927. She died on 23 Jan 1992 at age 96.
Anna was enumerated in the 1900 Census in the household of her grandfather, Christian Charles, and in the 1910 and 1920 Census in the household of her uncle, Abraham Charles.
Casper Schmuck Eberly was born on 24 Aug 1885. Casper was enumerated as a Farmer in the 1920 Census in East Hempfield Twp. and in the 1930 Census in Ephrata, both in Lancaster Co., PA.


Further information, I use Custom format and Abbreviated events for children; only children that are carried forward.

Thoughts on bug or me? Thanks


ipb.global.registerReputation( 'rep_post_57281', { domLikeStripId: 'like_post_57281', app: 'forums', type: 'pid', typeid: '57281' }, parseInt('0') );

#3 pgarrido

pgarrido
  • Members
  • 9 posts

Posted 26 January 2012 - 08:34 AM

Joe,
I also have the same problem and allready posted the following post:

I have allready sent to Wollygenes suport, a few Word "Journal/decendent reports", where I got two strange formatings.
1. An extraline /carriage return, on both spouse paragraph and children paragraph?! I did not find yet if it hapens randomly or it has to do with something specific.
2. On children's paragraph, isometimes, it appears the text: "Name was…".
This strange formating applyes both to Word and Print preview.
Does anyone have the same problems?
Regards,
Pedro Garrido

#4 Joe LaPointe

Joe LaPointe
  • Members
  • 15 posts
  • Gender:Male
  • Location:Sunnyvale, CA

Posted 26 January 2012 - 04:48 PM

I have found the cause of my problem. I would call it unexpected behavior in the report writer. Here is the cause and solution.

Let's start with the journal report for Nicolas Audet. In order to improve the readabilty of the journal report, I added two carriage returns to the beginning of Madeleine Després baptism tag so I would get a blank line before the start of Madeleine's narrative. These two carriage returns had an unintended consequence; her name was added to the beginning of the narrative, a blank line was inserted, then her narrative.

My solution to this problem was to create a "Blank Line" tag with a sentence of [:CR:]. Using the appropriate sort date, I then add a Blank Line tag after Nicolas' burial tag. The problem went away.

The issue with the journal report for Innocent Audet is the same as for Nicolas Audet. The solution was the same.

Hope this helps!

Joe LaPointe

#5 Terry Reigel

Terry Reigel
  • Moderators
  • 4,643 posts
  • Gender:Male
  • Location:Boone, NC

Posted 27 January 2012 - 01:20 PM

Joe,

TMG always makes the subject's name the first item in the narrative about that person. If the first Tag printed starts with the person's name, that is used. But if the first Tag starts with something else, as in your case a carriage return, then the report puts the name there before printing the first Tag. I think that's what you were seeing.
Terry

See my Tutorials and Articles on using TMG at tmg.reigelridge.com

The Second Edition of my book, A Primer for The Master Genealogist, is still available
. For more information see my website.

#6 Joe LaPointe

Joe LaPointe
  • Members
  • 15 posts
  • Gender:Male
  • Location:Sunnyvale, CA

Posted 27 January 2012 - 03:34 PM

Terry,

I understand what you are saying. From my perspective, the report generator is deficient if I have to resort to using Blank Line tags to make journal reports more readable, i.e., wanting a blank line between the husband narrative and the wife narrative in a journal report.

Regards,
Joe

#7 Terry Reigel

Terry Reigel
  • Moderators
  • 4,643 posts
  • Gender:Male
  • Location:Boone, NC

Posted 27 January 2012 - 03:47 PM

You are talking about a Journal in which specify "Include Spouse Events," so that the spouse's events follow those of the subject, right?

You can add a blank line by checking the "Blank line for each family" option on the Miscellaneous tab of report Options. It's near the middle on the right side.
Terry

See my Tutorials and Articles on using TMG at tmg.reigelridge.com

The Second Edition of my book, A Primer for The Master Genealogist, is still available
. For more information see my website.

#8 Joe LaPointe

Joe LaPointe
  • Members
  • 15 posts
  • Gender:Male
  • Location:Sunnyvale, CA

Posted 28 January 2012 - 11:09 AM

Terry,

Your suggestion worked as advertised. Thanks for the timely assistance.

Joe

#9 Terry Reigel

Terry Reigel
  • Moderators
  • 4,643 posts
  • Gender:Male
  • Location:Boone, NC

Posted 28 January 2012 - 03:37 PM

You're welcome, Joe. :)
Terry

See my Tutorials and Articles on using TMG at tmg.reigelridge.com

The Second Edition of my book, A Primer for The Master Genealogist, is still available
. For more information see my website.

#10 SmithOJ

SmithOJ
  • Members
  • 4 posts

Posted 29 January 2012 - 03:06 PM

Joe & Terry

After rereading Joe's initial post his problem is different than the one that I first posted about that I refer to above. I still see the same behavior in v 8.01 that I did in v 8.00.

I had sent an email to Wholly Genes tech support a few weeks ago and still have not heard anything back.

Glad that you solved your problem Joe but I am still trying!

Thanks
Oliver




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users