Jump to content


Photo

Remove "in" preceding a place name

Data Entry place names

  • Please log in to reply
3 replies to this topic

#1 dm7ich

dm7ich
  • Members
  • 7 posts

Posted 04 January 2013 - 10:19 AM

How can the word "in" preceding a place name be removed? It appears to be hard coded into the <L> variable as it does not appear when attempting to editing events. The issue is that, depending how I enter a place name, the word "in" makes the event sentence nonsensical. As an example, working with the Residence event, the only way I have found to force the sentence to read correctly is to insert the street address into the memo field (rather than in the detail field). A person resides "at" a street address "in" a city, not "in" a street address and city. For what should be an obvious reason, it would be much better to enter the street address into the detail field (provided the sentence would read correctly) and avoid having to enter it into every single memo field of every event where it is used. Alternately, one could use "at" preceding the detail and "in" for the subsequent city/place descriptors.

#2 Paul Lawrence

Paul Lawrence
  • Senior Members
  • 748 posts
  • Location:Fairfield Glade, Tennessee, USA

Posted 04 January 2013 - 12:02 PM

"in", "at", or blank preposition is determined by the setting in the Report Options-Places tab for the entire report. If you do not want a preposition for one particular tag then place an space in the location variable in the sentence template for that tag, i.e. "< L>". Anything you place in the variable will override the use of the default preposition, i.e. "<near L>", "<from l>", etc.
Paul E. Lawrence
WIN XP Pro SP3

#3 Vera Nagel

Vera Nagel
  • Moderators
  • 1,535 posts
  • Gender:Female
  • Location:Bevern, Lower Saxony, Germany

Posted 04 January 2013 - 12:03 PM

For reference please consult TMG's Help and i.e. search for: preposition

Quoting Help topic "Prepositions" it i.e. tells regarding "Places"

Places: The place is preceded with "at," "in," or nothing, according to the setting in the Places tab of the Report Options Screen for the report being generated.


That being said if you i.e. want to create an Individual Report for any person within your database > click on "Options" on the Report Definition Screen > in Report Options go to the "Places" tab and check any of the available options regarding "Prepositions" on the upper right.
Thanks, Vera

Moderator of the German TMG User Group

#4 dm7ich

dm7ich
  • Members
  • 7 posts

Posted 05 January 2013 - 07:49 AM

Awesome, both of your recommendations were exactly what I needed. I've made the fix and am pushing forward on cleaning my database. Thank You!





Also tagged with one or more of these keywords: Data Entry, place names

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users