Jump to content


Photo

Frequent re-register (under Windows 8)


  • Please log in to reply
7 replies to this topic

#1 daryl edmonds

daryl edmonds
  • Members
  • 92 posts
  • Gender:Male
  • Location:Adelaide, South Australia, Australia
  • Interests:Genealogy, the environment, reading, Alzheimer's

Posted 21 January 2013 - 08:19 PM

In the last few days, when opening TMG for the first time in the day, in the last 2 out 3 days, the “Unlock the Full Version” window comes up, says it’s an “expired trial version” and I have to go through the hassle of re-entering my registration details. If I click "close" so the program can open, naturally I can’t edit anything but under “Help>About....” all the registration details are there, including my registration number. It hasn't happened every day but often enough to be a pain in the proverbial!
 
I’m using v8.04 on a Windows 8 64-bit computer and have never had this problem before. Once TMG has been unlocked it behaves as expected, even when closing and re-opening the program several times during the day, when doing a rebuild of my Second Site database.
 
Has anyone else had this problem and found a cure? I couldn’t find anything using a search on the forum.
 
Daryl

Edited by Jim Byram, 04 March 2013 - 03:52 PM.

Thanks,
Daryl Edmonds
South Australia


#2 Helmut Leininger

Helmut Leininger
  • Senior Members
  • 263 posts
  • Gender:Male
  • Location:Vienna / Austria

Posted 22 January 2013 - 01:11 AM

Daryl,

 

I have encountered this experience several times on two different PCs but I have not yet been able to trace it down.


Regards
Helmut

#3 ggilbert1

ggilbert1

    Glenn Gilbert

  • Senior Members
  • 282 posts
  • Gender:Male
  • Location:Sumner, Washington, USA
  • Interests:Main surnames: Anderson, Gilbert, Graham, Vigne

Posted 24 January 2013 - 07:27 PM

:lookaround: See this message thread on TMG-L http://archiver.root...2-12/1356601696

 

Suggest you read through all the posts on this including this one http://archiver.root...2-12/1356610132


Edited by ggilbert1, 24 January 2013 - 07:29 PM.

Glenn Gilbert
Gilbert-Genealogy

#4 daryl edmonds

daryl edmonds
  • Members
  • 92 posts
  • Gender:Male
  • Location:Adelaide, South Australia, Australia
  • Interests:Genealogy, the environment, reading, Alzheimer's

Posted 29 January 2013 - 05:46 PM

Thanks for the links, Glenn.

 

However, I'm not using any registry cleaners or other "add-ons". I've been using the same anti-virus software for 10+ years (ESET NOD32); nor did I have this problem with Windows 7. Today (30 Jan) is the first time it's happened since my original post (22 Jan) so hopefully the events may be getting further apart and eventually disappear!


Thanks,
Daryl Edmonds
South Australia


#5 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 29 January 2013 - 06:57 PM

It is not a TMG issue and other programs are affected as well. It is some Windows 8 issue... perhaps the automatic maintenance that happens once a week. What happens is that the registry virtualstore is cleaned and this removes the registration of any program that has the data stored there. I've been looking for a solution but haven't found one yet.

 

More...

On my system, Win8 automatic maintenance was run this morning and the registration data in the registry VirtualStore was cleared so this is the source of the issue. Although the automatic maintenance is run daily and this only happens weekly.

 

I've asked a programmer to revisit the virtualization issue and to look for some resolution for TMG8.



#6 daryl edmonds

daryl edmonds
  • Members
  • 92 posts
  • Gender:Male
  • Location:Adelaide, South Australia, Australia
  • Interests:Genealogy, the environment, reading, Alzheimer's

Posted 09 February 2013 - 10:17 PM

Thanks, Jim.

I hope you can find a solution soon.

At least it's good to know that it's not something I've done or can control!


Thanks,
Daryl Edmonds
South Australia


#7 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 04 March 2013 - 02:55 PM

There is a solution that you can use to make this go away. (And this also works with TMG7 and any other program that has this issue under Windows 8.)

 

The next time that Win8 deletes the registration data...

1) Run TMG8 once as administrator (by right-clicking on the shortcut and selecting 'Run as administrator').
2) Unlock.
3) Exit TMG.

Now the registration data will no longer be deleted by the system.



#8 daryl edmonds

daryl edmonds
  • Members
  • 92 posts
  • Gender:Male
  • Location:Adelaide, South Australia, Australia
  • Interests:Genealogy, the environment, reading, Alzheimer's

Posted 13 March 2013 - 05:45 PM

Thanks, Jim, I'll do that when it happens again next week.


Thanks,
Daryl Edmonds
South Australia





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users