Jump to content


Photo

Relationship to You Custom Tag


  • Please log in to reply
18 replies to this topic

#1 patj

patj
  • Members
  • 17 posts

Posted 09 April 2013 - 05:19 PM

In TMG 8.04, I created a custom tag, Relationship to You, to record nonblood relationships, as in the online Ancestry Family Tree. On my new computer, TMG was automatically upgraded to 8.06, and now my custom tag does not work. TMG will not allow me to just delete the tag, because it is attached to people in my database.Are there any solutions?



#2 Michael Hannah

Michael Hannah
  • Moderators
  • 2,733 posts
  • Gender:Male
  • Location:Los Ranchos, New Mexico, USA
  • Interests:Genealogy, Computers

Posted 10 April 2013 - 10:08 AM

What are the symptoms you are seeing that cause you to say "my custom tag does not work"?  Perhaps one of us users can recommend a way to make it work.


Michael
See my book on how I customize TMG My Way.
My website.

#3 patj

patj
  • Members
  • 17 posts

Posted 10 April 2013 - 04:10 PM

When I click on the tag to use it I get this error: Variable 'LAROLES' is not found  60 FRMEVENTS.MCREATEROLES2

 

I think that there is supposed to be "Principal" in the boxes in the upper left of the Tag Entry Box, but these boxes are blank, and the ID number and name of the person should display, but this is blank as well. If I continue and enter the relationship in the Memo field, I get the following error: operator/operand type mismatch.  5 FRMEVENTS.CNTPARENTCHILD1.MVALIDATE

 

If I do a lookup and enter the person for the tag, I get an error: The same person has been entered as a Principal more than once.

 

None of the custom tags entered in TMG 8.04 are displaying in TMG 8.06. 

 

It's even difficult to Cancel or Exit from the error messages.

 

If there is no solution, I think I will just use the "Note" tag for the same relationship info. I'll have to start over and enter the "Note" tag for the 500+ people that already had the custom tag in TMG 8.04



#4 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 11 April 2013 - 07:44 AM

Please upload a backup of your v8.04 project to the Wholly Genes server using Help / Message Manager / Outgoing tab. After the file is uploaded, let me know the name of the file so that I can retrieve it.

 

I'll check your custom tag type and the update to a current version.



#5 patj

patj
  • Members
  • 17 posts

Posted 11 April 2013 - 12:55 PM

The backup file was uploaded. File name is D:Johnson Family 2012-10-05 22-47-42.sqz



#6 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 11 April 2013 - 01:30 PM

Thanks. I got it and will take a look.

 

You have two documents folders... one called Documents and one called My Documents.

 

Looking at the tag type table in your v8.04 project... There is no custom tag type named 'Relationship to you'.

 

Did you send me a backup made before you added the custom tag type?

 

After updating to v8.06, your project has no role issues and looks fine.


Edited by Jim Byram, 11 April 2013 - 01:47 PM.


#7 patj

patj
  • Members
  • 17 posts

Posted 11 April 2013 - 01:52 PM

Thanks for looking at the file. I will just use the "Note" tag from now on, since I have no problem with that tag.



#8 Michael Hannah

Michael Hannah
  • Moderators
  • 2,733 posts
  • Gender:Male
  • Location:Los Ranchos, New Mexico, USA
  • Interests:Genealogy, Computers

Posted 12 April 2013 - 08:08 AM

But if the file you sent has none of the 'Relationship to you' tags in it, you must have sent the wrong file?  We want to identify the problem.  If you are having problems, so might others.  But we can't help without looking at a file that at least has these tags, much less the problem.  As Jim said, the file you sent upgrades to 8.06 without problems, probably because it has none of those tags.


Michael
See my book on how I customize TMG My Way.
My website.

#9 patj

patj
  • Members
  • 17 posts

Posted 12 April 2013 - 11:51 PM

Does the file have to be the *.sqz file or can it be the *.PJC file? Would you also need any of the other files, such as CDX files or DBF files? I don't have a more recent *.sqz file than the one that I uploaded already.



#10 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 13 April 2013 - 12:22 AM

It needs to be a complete set of the v8.04 project files (without the CDX files). A project is comprised of the full set of files, not any one file or filetype.



#11 patj

patj
  • Members
  • 17 posts

Posted 13 April 2013 - 10:17 PM

I uploaded my PJC file. File name is G:UserspatjMy DocumentsThe Master Genealogist v8 Old ComputerFiles to Upload to TMG SupportJohnson Family_.PJC

 

The date on the file is 20 Mar 2013 which is the day that a power outage destroyed the mother board on my computer. I was going to send multiple files, but it seems that Message Manager will upload only one file at a time. 



#12 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 14 April 2013 - 05:54 AM

Hopefully, you were not using TMG at the time of the power outage. If that were the case, you might have a damaged project.

 

Like I said, a TMG project is a set of files and the set of files needs to be uploaded. If you don't have a backup with the custom tag type being discussed, you will need to use a ZIP file utility to make a ZIP archive of the folder with your TMG v8.04 project and upload that archive (which will be a single file containing the many archived files).

 

If you need help with this, you should contact Support and let Dorothy work through archiving your files with you.



#13 Virginia Blakelock

Virginia Blakelock
  • Moderators
  • 3,178 posts
  • Gender:Female
  • Location:Ohio

Posted 14 April 2013 - 06:01 AM

patj -

 

Jim said:

"You have two documents folders... one called Documents and one called My Documents.

Looking at the tag type table in your v8.04 project... There is no custom tag type named 'Relationship to you' "

 

Is it possible that you have two copies of the project - one restored to My Documents and the other to Documents - and one project has that custom tag and the other copy does not, and you are looking at the copy without that tag?

 

Note that a project contains 80 or more files.  The .pjc file is a simple text file that TMG uses to open your project.  When you Backup your project, TMG bundles the 80+ files  into the compressed .sqz file that Support needs.

 

To locate all the projects on your computer, go to the Windows Start button and in the 'Search programs and files' field, type in *.pjc.  That will find all your projects - and any duplicate if there is one.

 

Virginia


Win7 Professional x64

#14 patj

patj
  • Members
  • 17 posts

Posted 14 April 2013 - 08:27 PM

The extra "My Documents" folder is some folder that my computer manufacturer placed on there. When I click on it, an error message tells me I don't have access to that folder. I think it is empty anyway. I can't edit or delete it even though I am the Administrator and the ONLY user of this computer. The other "My Documents" folder is the one that has my TMG files. 

 

I uploaded the following file which has all the project files from February and March 2013 before the 20 March power outage.  File is C:Hamster ArchiveFiles to Upload to TMG Support.zip

 

I also uploaded a zip file of the whole Projects folder. This is D:Projects.zip



#15 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 15 April 2013 - 06:04 AM

The only complete set of files is in the ZIP of the entire Projects folder. It has a v8.04 project dated 20 Mar and that project does contain the 'Relationship to You' tag type. And I see the problem with updating this tag type from v8.04 to the new role structure. Now we've got something to work with. Sent the project to the programmer so that the update can be followed under a debugger.



#16 patj

patj
  • Members
  • 17 posts

Posted 15 April 2013 - 11:20 AM

Thanks for your time and efforts with my TMG problem. It's strange that no one else encountered this problem. Perhaps because my project did not get updated to 8.05, before going to 8.06. At least it's not such a monstrous problem that it prevents TMG from being used. And I can still use the "Note" tag to record the information on nonblood relationships. How will I find out if the programmers find a solution? Will it be in this thread?



#17 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 15 April 2013 - 11:28 AM

Actually, I found the issue and can fix your current project. The 'Relationship to You' tag type sentence field in your v8.04 project was damaged and that is the only issue. That caused any subsequent problems.

 

A bit of advice... If you don't want a tag type to have output, you should mark the sentences with exclusion markers rather than blanking the sentence fields. The damage went beyond this but it looks like that's what you tried to do.

 

Contact me by clicking on the email link below. Send me the johnson family_t.dbf and johnson family_t.fpt files from your current v8.06 project folder and I'll fix the 'Relationship to You' tag type. You should copy those files to your desktop and make a ZIP archive with them and send me the ZIP file.

Jim Byram


Edited by Jim Byram, 15 April 2013 - 04:17 PM.


#18 mstone

mstone
  • Members
  • 2 posts

Posted 01 August 2013 - 10:32 AM

Just moved this to a new thread, as this reply is not getting any answers....

 

I too am having a similar problem with a custom tag, with just one of my three projects in TMG 8.08, and it didn't appear until recently. When I try to enter a custom "Obituary" tag (that I created a long time ago in Version 7 or earlier), I get the message: "Variable 'LAROLES' is not found. 61  FRMEVENTS.MCREATEROLES2". Then trying to back out of these tag boxes, I get messages "Operator/operand type mismatch 4 FRMEVENTS.CMDCANCEL.CLICK" or "Operator/operand type mismatch 5 FRMEVENTS.CNTPARENTCHILD1.MVALIDATE". I keep clicking Abort, Try, and Ignore until I eventually get to a box with this message: "Unknown member ROPROTECTIONMAN." Then I can only get out of TMG by hitting Control-Alt-Delete and aborting it with Task Manager. (ESCape key does not work).

 

I have also noticed that on at least two of my individuals in this project, their death tags have lost their Primary designation, and within their obituary tags, where it should say "Principal" near the top of the tag data entry box it says ".F. " The drop-down list of options in that box, instead of Principal and other roles, has a long list of many  ".F."s, and the option "New" at the bottom of the list.

 

I checked and made sure I am not showing cue cards, and have "Allow Multiple Monitors" turned off. Have tried this many times since last night, restarting my machine in between, and it's really stuck in this loop. But my other two projects seem fine--so far. Can you help?


Edited by mstone, 01 August 2013 - 12:46 PM.


#19 tynrhos

tynrhos
  • Members
  • 1 posts

Posted 19 September 2013 - 09:55 PM

I am having this same problem as mstone describes.   It's only when I want to add a tag that I get the LAROLES error #61, (and all the rest of them). 

 

I'm not trying to add a custom tag just a normal note, or death tag.    and I get the drop box full of ".F." 

 

I can actually enter info in the tag if I ignore the warning, and it will show up when I restart the program as a normal looking entry. 

 

But I can't just enter my info and then exit the tag. 

 

As best I recall, I have not made a custom tag yet.

 

I am using v8.08, win7 ultimate 64bit,   16gb memory,   i5-2500k  3.3ghz

 

Is this something I can fix?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users