Jump to content


Photo

have to unlock program every time i use

unlock

  • Please log in to reply
8 replies to this topic

#1 cc1158

cc1158
  • Members
  • 7 posts
  • Gender:Female
  • Location:TX

Posted 02 September 2013 - 12:07 PM

have version 8 but for some reason it won't stay unlocked,  which is a pain as it is a loooonggg unlock

  what can i do?



#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 02 September 2013 - 12:16 PM

Are you running Windows 8?



#3 cc1158

cc1158
  • Members
  • 7 posts
  • Gender:Female
  • Location:TX

Posted 02 September 2013 - 12:24 PM

yes i have windows 8



#4 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 02 September 2013 - 02:49 PM

There are two possibilities... the Windows 8 issue or a registration issue. Here is the fix for the Windows 8 issue.

 

Windows 8 has a 'feature' that didn't occur in earlier operating system versions.

When you run as a Standard user and unlock TMG7 and TMG8, the program does not have the permission to write the registration information to the Registry, so the information is virtualized and written to the registry VirtualStore.

With WinVista and Win7, this worked fine.

Windows 8 comes along and periodically purges the registration information from the registry VirtualStore. That is why the program is locked again.

%%%%%%%%%%

The solution...

Step 1) You need to delete the registry key containing the virtualized information. This step is required for the solution to work.

On my system, the registry path is:
HKEY_USERSS-1-5-21-280371975-2347893702-1721369835-1000_ClassesVirtualStoreMACHINESOFTWAREWow6432NodeWholly
Genes SoftwareThe Master Genealogist V7
and
HKEY_USERSS-1-5-21-280371975-2347893702-1721369835-1000_ClassesVirtualStoreMACHINESOFTWAREWow6432NodeWholly
Genes SoftwareThe Master Genealogist V8

Your registry path(s) will be something similar.

Step 2) After deleting the registry key, you need to run TMG ONCE as Administrator and unlock the program.

Right-click on your TMG desktop shortcut and select 'Run as Administrator' to start TMG and then unlock. After unlocking, exit TMG.

Step 3) After the above steps, you can run TMG as a Standard user and the registration information will no longer be lost.

 

%%%%%%%%%%

 

If that doesn't work, I'll add the fix for the registration issue.



#5 cc1158

cc1158
  • Members
  • 7 posts
  • Gender:Female
  • Location:TX

Posted 02 September 2013 - 08:22 PM

i'll try,

if i can figure this out



#6 Virginia Blakelock

Virginia Blakelock
  • Moderators
  • 3,178 posts
  • Gender:Female
  • Location:Ohio

Posted 03 September 2013 - 06:08 AM

Contact support (support@whollygenes.com) and see if they can walk you though it.  In the meantime, you might try another possible fix.  Rightclick on your TMG v8 icon on your desktop and select 'Run as Administrator.'   Do this one time only.

 

Virginia


Win7 Professional x64

#7 cc1158

cc1158
  • Members
  • 7 posts
  • Gender:Female
  • Location:TX

Posted 03 September 2013 - 09:17 AM

Virginia,  i think yours may have worked



#8 Virginia Blakelock

Virginia Blakelock
  • Moderators
  • 3,178 posts
  • Gender:Female
  • Location:Ohio

Posted 03 September 2013 - 09:42 AM

That is good.  I hope it is just not a temporary fix.  Keep us posted.  Again, you should run as Administrator this one time only, and note that 'running' as Administrator is different from 'logging in' as Administrator - which you should not do at all.

 

Virginia


Win7 Professional x64

#9 cc1158

cc1158
  • Members
  • 7 posts
  • Gender:Female
  • Location:TX

Posted 03 September 2013 - 12:51 PM

i've restarted my computer and logged back in okay  no unlock problems so far :wink:







Also tagged with one or more of these keywords: unlock

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users