Jump to content


Photo

Managing Data Files in Windows 8.1


  • Please log in to reply
6 replies to this topic

#1 Jim Rassette

Jim Rassette
  • Members
  • 43 posts
  • Gender:Male

Posted 19 January 2014 - 08:24 AM

My old computer (Windows XP from the late 1990s) died last weekend and I bought a new one with Windows 8.1. In the old system I had my programs and all my data on drives other than the C drive because of limited space on the C drive. I was able to recue all the drives out of the old computer and make them external drives to my new laptop. I had already updated to TMG version 8.08 on the old computer and was using the multi drive setup fine for all my project files.

 

Now with the new system I am having trouble getting TMG to take changes to preferences in the saved projects that open OK from the external drive data drive that I saved. The TMG  program remembers the change to the default Project Path I make on the general tab under Program Options. However, when I reset the paths on the advanced tab under Current Project Options to reflect how my files are currently (only a drive letter change from the old setup) the TMG program immediately overrides all but two of the paths to the default C:UsersnameDocumentsThe Master Genealogist v8... (configuration files, export, repeat files, report output, slideshow, and timelines). It leaves backups and exhibit folder alone. I assume because I selected don't change exhibit folder. Even when I fully retype all the paths to be what I need them to be now, TMG does not recognize the changes when I next open the project.

 

So far I have not made any other changes to any projects except for the preferences change in one project, but I need to resolve this issue so I can continue with my research.

 

I seem to remember this being discussed before but I could not find the thread.

 

 


Jim Rassette

#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 19 January 2014 - 09:38 AM

The Advanced path settings open to the default path when you click the browse button. You can then navigate to any valid path and select it. You need to do this for each of the paths on the Advanced tab.



#3 Jim Rassette

Jim Rassette
  • Members
  • 43 posts
  • Gender:Male

Posted 19 January 2014 - 11:24 AM

Thanks, Jim, for your quick reply.  I also tried that yesterday when typing did not work. However, I just tried it again being very sure to select the correct path I needed for everything except Slideshow and Timelines. I then clicked both apply and OK to exit the Preferences screen. I then selected Validate File Integrity, added the exhibits folder for this project and received the error saying all my exhibits were missing. I closed the project and reopened it to find the same problem with the paths on the Advanced-Current Project tab. The changes are not remembered, although all the other options that I had originally set for the project when on the old machine are there for the project and remain unchanged.

 

Why does TMG try to force a change? I can understand giving a warning about the path not being found but TMG should never change the entries before I can inspect and fix them.

 

To me there are two problems here:

 

1. Not updating the path changes properly

 

2. Overwriting what was typed originally in the path fields on the advanced tab for the project

 

 

Thanks,


Jim Rassette

#4 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 19 January 2014 - 01:29 PM

The exhibits paths have nothing to do with the Advanced setting other than that being the default path when opening the dialog to add a new exhibit.

 

The exhibit paths will be incorrect when running VFI and the stored exhibit location does not exist. If you add the folder path(s) where the exhibit files exist in VFI and then run VFI, it will find the exhibit files and update the paths.



#5 Jim Rassette

Jim Rassette
  • Members
  • 43 posts
  • Gender:Male

Posted 19 January 2014 - 04:37 PM

I agree with you about the VFI but that is not the issue that is causing a problem.

 

The problem is TMG is not updating the paths or is ignoring the saved changes when I reopen the project after changing the paths on the advanced Project Options screen. I cannot use the program if it will not take the changes.


Jim Rassette

#6 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 19 January 2014 - 06:58 PM

That's not something that I've ever seen or know how to replicate.

 

Your project is not in some read-only folder?

 

btw... You don't need to click both [Apply] and [OK]. [OK] does the same as [Apply] plus exiting Preferences.



#7 Jim Rassette

Jim Rassette
  • Members
  • 43 posts
  • Gender:Male

Posted 19 January 2014 - 08:32 PM

As an experiment after the ball game I copied the entire tree of my TMG v8 data files off of the external drive they were on to the C drive of my new laptop. I then opened TMG and picked up the project in the new location, made the path changes and everything worked fine.

 

I had previously checked the permissions on the external drive and everything looked fine, but nothing worked when I used the external drive.

 

I'll have to do some more experimenting.

 

Thanks for your help.


Jim Rassette




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users