Jump to content
Sign in to follow this  

Another printer problem, actually a few

Recommended Posts

I installed TMGW 9.05 late last year when it was released. Due to family demands, I have not attempted to print anything until now. When I went to a report, I found that I can find the printer I have physically attached to my system (not wifi), but I receive an error when I try to print to it.


I selected the Family Group Sheet to print, and sent it directly to the printer. The error I receive is:


OLE error code 0x80040154: Class not registered.


If i click "Ignore", the dialog box goes away but nothing happens - nothing prints.


When I attempted to print to the PDF printer, TMGW notifies me that it is not installed, even though I installed it from the File/Printer Setup menu when I first installed. If I attempt to re-install it, the install appears successful, but again I cannot print to it, I get the "not installed" message.


I also have the CutePDF printer writer installed, and have tried to print to that. To an application, it simply looks like another printer. When I tried printing to it, I got the OLE error code (same as above), plus another error - "Unknown member ROPROTECTIONMAN." When I click on OK, I get a screen that is a Windows File Save window, with no file name and and file type of "Table/DBF (pdf)". When I get this, I cannot do anything else, and have to terminate TMGW through the Windows Task Manager.


I have completely removed (uninstalled) TMGW following the instructions at the "TMG9 - Final Installers" thread by Jim Byram, and reinstalled with a new download from his links. Same printer problems.


I receive the same problems regardless of the report I select. I can, however, get a report preview, but cannot route it to any printer.


Running Windows 7 on an AMD FX processor with 16GB memory.

Edited by gdlemail

Share this post

Link to post
Share on other sites

Jim, did as you suggested, even downloaded a fresh copy of the installer to effect the repair. Rebooted the computer as well, but the same problems persists.


Have previously also run all of the TMG maintenance utilities to ensure the database is indexed and optimized. No problems reported.

Share this post

Link to post
Share on other sites

This problem has nothing to do with your data. It's a program installation issue.


The issue is an unregistered control and [Repair] should have fixed it.


I probably have a manual fix but the information is on another computer. I'll add to this later.

Share this post

Link to post
Share on other sites

Jim should be able to help you with your primary printing problem.


However, I noted that you said:

When I attempted to print to the PDF printer...


You probably already know this, but just to be clear to anyone else reading this thread, you do not set the Printer options to "Print" to a PDF printer. To create a PDF file you simply "Save to" a File type of "Adobe Reader (PDF)". TMG then uses its installed PDF printer code to create the PDF file.

Share this post

Link to post
Share on other sites

As Michael says, the Wholly Genes PDF Writer v4 is only used when you select the report output type as 'Adobe Reader (PDF)' and can never be used directly as a selected printer.


If this is not the issue, here is a manual fix for the report output problem...


The error occurs because a file cdintf400.dll used by the PFD driver is not registered.
Try this first. Go to the Devices and Printers folder and remove the 'Wholly Genes PDF Writer v4' printer driver. Then start TMG and install the PDF driver (File / Printer Setup). The driver might install automatically when you start TMG. That's OK.
Then try the reports again. If this didn't fix the problem, a manual fix is below.
1) Close TMG
2) Click on the Windows button
3) Type "cmd" (no quotes) in the "Search programs and files" field.
4) cmd.exe should appear at the top of the list. RIGHT-click on it and choose "Run as administrator" (very important!)
5) type: "cd \windows\syswow64" (as always, no quotes) (or "cd \windows\system32" for a 32-bit system) and press enter.
6) type: "regsvr32 cdintf400.dll /u" and press enter. You should get a message that it succeeded.
7) press the up arrow and the previous line should be repeated. Hit twice to remove the "/u"
(or type "regsvr32 cdintf400.dll" from scratch) and press enter. You should get another message that it succeeded.
8) Type "Exit" and press Enter to close the window (or click on the X if that works)

Share this post

Link to post
Share on other sites

First off, - success!


Michael - thanks for the correction. I spoke out of habit from my use of the CutePDF "printer" which IS used by selecting it as a printer. I know that TMG has a pdf output you select to save to, which also was not working. I just chose wording that was habit and not accurate in this case.


Jim -


Oddly, the TMG pdf printer did not show up in my printer list, even after numerous "successful" installs (according to the Amyuni install reports), so nothing to delete.


I followed your manual instructions, everything went as you described, and I restarted TMG. I printed successfully to paper, but when I went to "Save to" (!!!) the TMG pdf printer, TMG hung up. I had to terminate TMG through the Task Manager (which showed TMG as "Not Responding"), but I noticed it did create the file I wanted. I have other programs running at the moment, and need to get an email out, then I will reboot and see if that helps.

Share this post

Link to post
Share on other sites

Update after reboot: the pdf file originally created when TMG hung up was corrupt and Adobe could not open it.


I deleted the TMG printer and went to reinstall it, and lo and behold, it was there again - the Amyuni installer infomed me that the printer was already installed.


I can print to my printer and to my CutePDF printer, but cannot save to a pdf file using the TMG facility. I get an error:


TerPrint2, Error Code: 771

Unable to Start the Print Job.


When I clicked OK, TMG went ahead and told me it had successfully created the file. I selected "Open" the file, but adobe told me the file could not be opened as it was corrupt.


Since I can use the CutePDF printer to create a PDF file, no loss on the lack of TMG pdf facility, but I do not like quirky software running on my system. Any thoughts?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this