Jump to content


Photo

Printing Reports


  • Please log in to reply
9 replies to this topic

#1 Ron Stonehouse

Ron Stonehouse

    Ron Stonehouse

  • Members
  • 74 posts
  • Gender:Male
  • Location:Edmonton Alberta Canada

Posted 28 February 2016 - 07:54 AM

Good morning, I originally posted this on February 23, 2016 on the TMG-List and received suggestions from two list members. After trying their suggestions, I still have no solutions, so I'm posting it here in the hopes that someone on the list has the solution. As a point of interest I tried to print various reports to the screen (as well as other output options)  but they all seem to want to go to a RTF file. I really need to fix this problem so any and all help is appreciated.

 

TIA

-----------------------------------------------------------------------------------------------

I hope someone has a solution to this problem. I trying to create an indented descendant chart for a specific individual and to have the output checked to go to the screen. However, each time I generate the report the output is sent to a .rtf file even though the screen preview option is the only option checked for output in the report destination portion of the report. I have reset the report to defaults but not even this has helped.

 

Can anyone help?

 

Ron

 

PS I'm running Windows 10 64 bit fully patched.


Ron Stonehouse

#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 28 February 2016 - 08:01 AM

The screen preview is an .RTF file by design. In other words, when you select screen preview and generate the report, a .RTF file is created and then displayed in the screen preview window. You are saying that preview doesn't display and only a file is created?

 

Have you tried resetting the report configuration?

 

I would also run the installer for the TMG version that you are running and select [Repair].



#3 Ron Stonehouse

Ron Stonehouse

    Ron Stonehouse

  • Members
  • 74 posts
  • Gender:Male
  • Location:Edmonton Alberta Canada

Posted 28 February 2016 - 08:11 AM

The screen preview is an .RTF file by design. You are saying that preview doesn't display and only a file is created?

 

Have you tried resetting the report configuration?

Yes you are correct. Only the file is created and it is not displayed on the preview. I just reset the default settings for this report and re-ran it and that did not fix the problem. I have also uninstalled TMG and reinstalled and this did not help.


Ron Stonehouse

#4 Ron Stonehouse

Ron Stonehouse

    Ron Stonehouse

  • Members
  • 74 posts
  • Gender:Male
  • Location:Edmonton Alberta Canada

Posted 28 February 2016 - 10:17 AM

Jim, I resolved the problem, I hope. I had to uninstall Microsoft's Windows 10 built-in PDF printer and then reinstall TMG's pdf printer. Seems to be working but I will have to keep an eye on it for future reports. I've tested it with Descendant Indented and List of people with a filter.

 

thanks for your suggestions


Ron Stonehouse

#5 Bruce Barker

Bruce Barker
  • Members
  • 5 posts

Posted 28 February 2016 - 03:44 PM

Thanks for sharing your solution (temp or otherwise), Ron.  I have had that problem under win 7 for a long time and been frustrated enough to put my research aside.  I hope your solution works, and if it doesn't please keep us posted!

Bruce



#6 Ron Stonehouse

Ron Stonehouse

    Ron Stonehouse

  • Members
  • 74 posts
  • Gender:Male
  • Location:Edmonton Alberta Canada

Posted 27 March 2016 - 12:13 PM

 

The screen preview is an .RTF file by design. You are saying that preview doesn't display and only a file is created?

 

Have you tried resetting the report configuration?

Yes you are correct. Only the file is created and it is not displayed on the preview. I just reset the default settings for this report and re-ran it and that did not fix the problem. I have also uninstalled TMG and reinstalled and this did not help.

 

Ok, so my problem has returned. Even though I had it working, now I still can't preview to the screen. It seems Windows 10 arbitrarily re-installs the Windows 10 PDF driver and printer along with "send to one note" neither of which I use nor want to at this time. I'm still hopeful that someone has an answer for me..


Edited by Ron Stonehouse, 27 March 2016 - 12:14 PM.

Ron Stonehouse

#7 John Cardinal

John Cardinal
  • Senior Members
  • 835 posts
  • Location:North Andover, MA

Posted 29 March 2016 - 07:30 AM

Ron,

 

What version of TMG are you using?



#8 Ron Stonehouse

Ron Stonehouse

    Ron Stonehouse

  • Members
  • 74 posts
  • Gender:Male
  • Location:Edmonton Alberta Canada

Posted 29 March 2016 - 07:33 AM

Ron,

 

What version of TMG are you using?

 John I'm using TMG 9.05.


Ron Stonehouse

#9 tkstone

tkstone
  • Members
  • 3 posts

Posted 14 April 2016 - 11:15 AM

Pardon my joining this conversation, but I thought my concern might fit in. I tried to do>  Report: Pedigree: File. And got the following messages: "Printer not activated, Error Code -30" (but it is) and "Unable to Start Print Job (TerPrint2, Errof Code 15." When I try to "Install Printer," I am told that the printer is already installed, and it is, but it does not appear among the options in the TMG print options. Can someone tell me what is wrong? Thank you.



#10 tkstone

tkstone
  • Members
  • 3 posts

Posted 14 April 2016 - 11:51 AM

Concerning my recent post above: I uninstalled, then reinstalled my TMG PDF printer and it solved my problem. (Win 7)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users