Jump to content

"Variable Go Term Not found" msg in windows 11

Recommended Posts

I installed Windows 11 using Parallels on my mac.  I then installed TMG 9 and had no issues.  Ran it an restored my project file from the backup. Closed TMG and then reopened it and got the message

"Variable Go Term not found".  

I did a repair via the installer, then uninstalled and reinstalled TMG several times.  Always I would get the message after trying to open TMG a second time.  What i causing this and how can I fix it?

Related to Windows 11, I cannot find the location of the *.lo files.



Share this post

Link to post
Share on other sites

There's a discussion of this issue.

The error basically has to do with the paths used by TMG for the various data folders and typically occurs when running TMG in a virtual environment or on a Mac under Parallels. There are solutions in that topic.

The question... Is the restored project using the default TMG data paths? The restored project might have been using an incompatible path for one of the settings. Check Preferences for the project path settings and make sure all are set to the defaults. 


The *.lo files are here... C:\Users\(user account name)\AppData\Roaming\The Master Genealogist v9

The folder can be accessed from TMG.

Help menu / Access Folders / select User Program Data Folder / [Open]

Share this post

Link to post
Share on other sites

Jim has given you the appropriate pointers to what is almost certainly the cause of your problem.

He mentioned the "User program data folder" and included a truncated screenshot from Rod.

If you have not seen the screen Rod included before, you access it from within TMG under the Help menu by selecting the menu item "Access Folders".  That screen will also identify the location of the "User program data folder" as the second item in the screen, which is cut off in the above screenshot.

Where the installer "expects" various data to be in Windows 11 is almost certainly not the old computer locations which the Restored project still points to.  As Jim said, you update the pointers for your new computer in Preferences for that Project.  There is one path defined in "Program Options / General",  but most are in "Current Project Options / Advanced".

Finally, if you have not already seen it, I strongly recommend you review Terry Reigel's excellent web page listing all the things you need to do when you transfer TMG and a project to a new computer, operating system, or version of TMG.  He specifically describes how to update the paths Jim is indicating in that page.  See: https://tmg.reigelridge.com/new-computer-version.htm

Hope this helps,


Share this post

Link to post
Share on other sites

That's not a screenshot. It's the link to the previous topic on this issue. This is how the message board handles a link to another topic.

Share this post

Link to post
Share on other sites


Thanks for the info.  It was my exhibits path that was having a problem.  I selected default when I opened the project again and this issue went away.,  funny Thing:  The "default" path 

is the one I originally setup.  At least that is what is seems like as all of my exhibits are displayed when checking.


Thanks again.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now