Jump to content


Photo

Can't Chat -- it fails


  • Please log in to reply
6 replies to this topic

#1 BillR

BillR
  • User Group Coordinators
  • 14 posts

Posted 20 August 2004 - 10:24 AM

The Wholly Genes Chat Room screen comes up, I get the Java icon in the dark field, wait a bit and then the Java icon is replaced with a red "X".
At the bottom of the Netscape 7.1 window is a note that "Loading Java Applet Failed...". I never get a chance to sign in or see who is there.

I've also tried it with a current version of IE -- same results.

Below is a copy of the Jave Console screen, if that helps. I'm running XP Pro (SP1).

Thanks, Bill. :wacko:


Java™ Plug-in: Version 1.4.1_07
Using JRE version 1.4.1_07 Java HotSpot™ Client VM
User home directory = C:\Documents and Settings\.....

----------------------------------------------------
java.net.SocketException: Unexpected end of file from server
at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)
at sun.plugin.cache.CachedJarLoader.download(Unknown Source)
at sun.plugin.cache.CachedJarLoader.load(Unknown Source)
at sun.plugin.cache.JarCache.get(Unknown Source)
at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect(Unknown Source)
at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile(Unknown Source)
at sun.misc.URLClassPath$JarLoader.getJarFile(Unknown Source)
at sun.misc.URLClassPath$JarLoader.<init>(Unknown Source)
at sun.misc.URLClassPath$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.misc.URLClassPath.getLoader(Unknown Source)
at sun.misc.URLClassPath.getLoader(Unknown Source)
at sun.misc.URLClassPath.getResource(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at sun.applet.AppletClassLoader.findClass(Unknown Source)
at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
load: class com.chatspace.v400320.Chat not found.
java.lang.ClassNotFoundException: com.chatspace.v400320.Chat
at sun.applet.AppletClassLoader.findClass(Unknown Source)
at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.net.SocketException: Unexpected end of file from server

at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at java.net.HttpURLConnection.getResponseCode(Unknown Source)
at sun.applet.AppletClassLoader.getBytes(Unknown Source)
at sun.applet.AppletClassLoader.access$100(Unknown Source)
at sun.applet.AppletClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
... 11 more

Edited by BillR, 20 August 2004 - 10:31 AM.


#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 20 August 2004 - 10:39 AM

Bill,

Bob and I just tried the chat and it worked fine for us. :unsure: I'm running WinXP SP-2, IE6 and Sun Java.

Jim

#3 Terry Reigel

Terry Reigel
  • Moderators
  • 4,643 posts
  • Gender:Male
  • Location:Boone, NC

Posted 20 August 2004 - 11:44 AM

I just tested it and it worked fine for me with IE. I know it doesn't work properly with Opera. I'd make a guess that it's a firewall issue, since neither of your browsers will work with it.
Terry

See my Tutorials and Articles on using TMG at tmg.reigelridge.com

The Second Edition of my book, A Primer for The Master Genealogist, is still available
. For more information see my website.

#4 BillR

BillR
  • User Group Coordinators
  • 14 posts

Posted 20 August 2004 - 01:19 PM

I just tested it and it worked fine for me with IE. I know it doesn't work properly with Opera. I'd make a guess that it's a firewall issue, since neither of your browsers will work with it.

<{POST_SNAPBACK}>


The firewall may be a good guess. I'm running ZoneAlarm Pro 5.1.011.000, but I'm probably not the only one using that or something similar. Is there anything special that needs to be set there? In the past I've tried turning it off but had the same problem.

Did anyone try to compare the Java version I have with what they're using?
(Java™ Plug-in: Version 1.4.1_07).

I tend to think this is a problem on my system, not a Chat problem, but thought I'd throw it out there for review.

Thanks,
Bill.

#5 joanmc

joanmc
  • Senior Members
  • 151 posts
  • Gender:Female
  • Location:Sooke, British Columbia, Canada
  • Interests:SURNAMES: BOWEN*, BUTTON, CARMEN*, CLEGHORN, COOK*, DAVIS, FALKNER*, GOWDY, HOUGH*, LINDSAY, McFARLAND, McILMOYL*, MIDDAUGH*, MILLS, MUNRO*, NEWMAN, NICHOLSON, SHAVER*, SIMPSON, SIPES*, WAIN<br /><br />* United Empire Loyalists<br /><br />Computers, Genealogy, History, Photography, Philosophy

Posted 20 August 2004 - 11:19 PM

The Wholly Genes Chat Room screen comes up, I get the Java icon in the dark field, wait a bit and then the Java icon is replaced with a red "X".
At the bottom of the Netscape 7.1 window is a note that "Loading Java Applet Failed...".  I never get a chance to sign in or see who is there.

I've also tried it with a current version of IE -- same results.

Below is a copy of the Jave Console screen, if that helps. I'm running XP Pro (SP1).

Thanks, Bill. :wacko:
Java™ Plug-in: Version 1.4.1_07
Using JRE version 1.4.1_07 Java HotSpot™ Client VM
User home directory = C:\Documents and Settings\.....

I use Mozilla and just checked - it works fine. I also run ZoneAlarm (not Pro).

B)
Joan
Joan McIlmoyl Cleghorn, U.E.
From Beautiful Saseenos, near Sooke & Victoria BC Canada
genealogy@joansjoy.ca
Joan's Joy of Learning

#6 BillR

BillR
  • User Group Coordinators
  • 14 posts

Posted 21 August 2004 - 05:41 AM

Here is more info on this problem. After further research, it appears to be related to using ZoneAlarm Pro Ver. 5. They made some changes in ZAP5 that cause Java applets to be dumped. At least one ZAP5 user found he had to turn off all security -- Cookies, Ad Blocking and Mobile Code control -- to get Java to work. Note that ZA (free version) does not have this problem and works OK ;)

I found that same action worked when I tried to get into the Chat. However, turning off Security is not the work-around that I like, so I may not be at the Chats too much. I will keep track of ZA and see if they fix this.

One interesting note: I found if I went into ZAP and turned all security off, went into Chat, and later left Chat and turned security back on, I could still go back into the Chat without problems. Rebooting the system, however, wiped out the ability to Chat again... :wacko:

Another note: I see that when I get the Chat screen up, the text on the left side states that the next Chat is scheduled for July 31 -- it hasn't been updated. I have tried "refresh" but no change there.

Bill.

Edited by BillR, 21 August 2004 - 06:01 AM.


#7 BillR

BillR
  • User Group Coordinators
  • 14 posts

Posted 05 December 2004 - 01:28 PM

Here is more info on this problem.  After further research, it appears to be related to using ZoneAlarm Pro Ver. 5. They made some changes in ZAP5 that cause Java applets to be dumped. At least one ZAP5 user found he had to turn off all security -- Cookies, Ad Blocking and Mobile Code control -- to get Java to work. Note that ZA (free version) does not have this problem and works OK ;) 

I found that same action worked when I tried to get into the Chat. However, turning off Security is not the work-around that I like, so I may not be at the Chats too much. I will keep track of ZA and see if they fix this. 

<{POST_SNAPBACK}>


Here's another update: I tried getting into Chat again today, and was successful, without removing ZoneAlarm or turning off security. Why? ---- I don't know.

My guess is that one of the updates to ZoneAlarmPro that I've installed since August fixed the problem with Java applets. I'm currently at ZAP 5.5.062.000. It's nice to see that I can now stay off of IE (I'm using Netscape 7.1) and keep my ZAP protection while still enjoying the Chat site.:)

Bill.

Edited by BillR, 05 December 2004 - 01:35 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users