Jump to content


Photo

Update to 8.02 aborted itself. Rollback erased entire program

8.02 install rollback

  • Please log in to reply
41 replies to this topic

#21 Jim Byram

Jim Byram
  • Moderators
  • 6,479 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 07 March 2012 - 01:22 PM

TMG did not install to the VirtualStore. The operating system did that.

I have no other ideas. You should contact Support and let them work through it with you.

#22 LDR

LDR
  • Members
  • 16 posts

Posted 07 March 2012 - 01:35 PM

Jim, where is the "Data File Storage help topic."? It is not a top level topic?

#23 Jim Byram

Jim Byram
  • Moderators
  • 6,479 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 07 March 2012 - 01:52 PM

Jim, where is the "Data File Storage help topic."? It is not a top level topic?

Use the help index.

In the help contents, it's the second topic under the File Menu.

#24 LDR

LDR
  • Members
  • 16 posts

Posted 07 March 2012 - 03:22 PM

I finally got an install that is working. The program did not install into a Program Files (X86)/The Master Genealogist ver 8, but rather into C:UsersLarryAppDataLocalProgramsThe Master Genealogist v8" , and that is fine with me.

I had to find and eleminate every occurance of anything associsted witth The Master Genealogist ver 8, clean my register and restart my machine, then run the install. Even then, after the install was complete, thesplash screen would not close. Since the program starts and appears to work properly, I assume it is properly installed? I guess I can get back to my genealogy now.

Will future updates, if any, install correctly now? Thanks for everyones help.

Larry

#25 LDR

LDR
  • Members
  • 16 posts

Posted 07 March 2012 - 03:27 PM

Jim, Thanks for the location of the storage files info. I get confused wether I should use the TMG Help files, or try to find them on the Help forum on line. I really don't want to know how the program works, I just want a genealogy tool.

Thanks

Larry

#26 Rod Deller

Rod Deller

    Old Sea Dog

  • Members
  • 15 posts
  • Gender:Male
  • Location:Cairneyhill, Fife, Scotland
  • Interests:Motorcycling, Photography, Family History, Computing.

Posted 08 March 2012 - 04:40 AM

I had the exact same problems installing V8.2 onto Windows 7 (64 bit). Following topics from top downwards I managed to resolve all issues and eventually get a good install. The only problem I now have is if I run a registry cleaner programme I have installed (ARO 2011) and then open TMG I have to re-insert my unlock code. However, if I ignore the unlock option the load form displays all my current unlock details correctly but TMG V8.2 loads with most menu options greyed out.

I am in contact with support trying to resolve this issue.
Rod
Posted Image
Scotland

#27 dsmer

dsmer
  • Members
  • 11 posts

Posted 08 March 2012 - 07:56 AM

Same thing here installing on Windows 7 starter. Deleting c:/programs/The Master Genealogist did the trick.

#28 STW

STW
  • Members
  • 3 posts

Posted 08 March 2012 - 10:34 AM

I have a non-standard install of TMG 8 and, as others have, crashed and burned with this latest update. I spent an evening trying to find all references to ver8 so I could delete them and start afresh. Apparently, there are more, well hidden, since I've yet to manage a clean update. I'll have more time tomorrow. Luckily, I've yet to try to update my primary computer. Losing the laptop, for now, just tells me that this update is not ready for release. A good release does not need to be worked around.

Here's my concern since I don't plan on updating my desktop. It is not worth the hassle factor for the limited added utility. My laptop and desktop share my primary database over a network. I only keep a backup on the laptop. Provided I can finally get the laptop to work again, can use the same database with a 8.01 and a 8.02 install?

#29 rhube

rhube
  • Members
  • 6 posts

Posted 13 March 2012 - 02:58 PM

I am yet another user stung by the 8.02 update.

I was running 8.01 on Windows 7 in a Parallels partion of my iMac (Lion). Then I made the mistake of trying the 8.02 update. Got the same missing file message and elected to rollback. That left me with nothing working. I've since attempted to fully uninstall TMG multiple times following all the recommendations given on this forum. Still can't get the trial version to install. It's been 2 days of trying everything you guys suggested. I think I'm gonna give up.

While I've been a loyal TMG users since the mid 90's, I just can't take the Windows issues any more! (and in the last year I've really started to appreciate how great the Mac and IPads are for stability).

My plan is to do one last TMG install on an old Windows machine I still have (and hate), port my data out to GEDCOM and bring it back into Reunion. Then Parallels and Windows is getting pulled off my Mac for good.

Sorry guys. I really do love TMG but it's just not enough to make me want to keep fighting Windows.

Regrettably.
--Randy

#30 JohnR

JohnR
  • Senior Members
  • 176 posts
  • Gender:Male
  • Location:Chiddingfold, Surrey
  • Interests:Genealogy, rhododendrons, lepidoptera

Posted 14 March 2012 - 01:37 PM

The same thing appears to have happened to me and I can't get a squeak out of Support nor can I find a trace of TMG8 on my computer. There seems to have been a disaster with each version of TMG. I was prevented from installing 7 as I had 6 so that I could continue with the programme and data on an external drive.

Quite frankly I feel that TMG support should learn to produce a product which runs as their customer wants (and has asked, with that customer's problems solved and not left outstanding for a couple of versions).

What genealogy prog is there which will work from a TMG database?

#31 Philip

Philip
  • Members
  • 6 posts

Posted 14 March 2012 - 09:35 PM

Use this procedure...

Uninstall. Delete any remnant program folder.

Delete the installer folder.
C:ProgramDataThe Master Genealogist v8 Installer

Download the 'trial version' installer from the whollygenes.com website.

Install and be sure to use the same program folder that you used for the current installation.

Now you should be up and running with v8.02.

%%%%%%%%%%

AFAIK... Wholly Genes has never tested installing TMG on WHS and an installation on that OS is not supported.


Tried this. I'm running Gold UK version 8.00 on Windows 7. I uninstalled version 8. Deleted the folders as above. Downloaded UK version 8.02. The install stops at the "Install" button. I waited 15 minutes. No rotating circular mouse pointer.

The last lines of the log read:

MSI © (BC:B4) [16:13:15:886]: PROPERTY CHANGE: Modifying CostingComplete property. Its current value is '0'. Its new value: '1'.
MSI © (BC:B4) [16:13:15:886]: Note: 1: 2205 2: 3: BindImage
MSI © (BC:B4) [16:13:15:886]: Note: 1: 2205 2: 3: PublishComponent
MSI © (BC:B4) [16:13:15:886]: Note: 1: 2205 2: 3: Font
MSI © (BC:B4) [16:13:15:886]: Note: 1: 2262 2: Class 3: -2147287038
MSI © (BC:B4) [16:13:15:886]: Note: 1: 2205 2: 3: TypeLib
MSI © (BC:B4) [16:13:15:886]: PROPERTY CHANGE: Modifying PrimaryVolumeSpaceAvailable property. Its current value is '0'. Its new value: '825021824'.
MSI © (BC:B4) [16:13:15:886]: PROPERTY CHANGE: Modifying PrimaryVolumeSpaceRequired property. Its current value is '0'. Its new value: '345577'.
MSI © (BC:B4) [16:13:15:886]: PROPERTY CHANGE: Modifying PrimaryVolumeSpaceRemaining property. Its current value is '0'. Its new value: '824676247'.
MSI © (BC:B4) [16:13:15:886]: PROPERTY CHANGE: Adding PrimaryVolumePath property. Its value is 'C:'.
Action ended 16:13:15: InstallValidate. Return value 1.
MSI © (BC:B4) [16:13:15:886]: Doing action: WelcomeDlg
Action 16:13:15: WelcomeDlg.
Action start 16:13:15: WelcomeDlg.


Can I send you the whole log?

#32 Jim Byram

Jim Byram
  • Moderators
  • 6,479 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 15 March 2012 - 05:34 AM

Tried this. I'm running Gold UK version 8.00 on Windows 7. I uninstalled version 8. Deleted the folders as above. Downloaded UK version 8.02. The install stops at the "Install" button. I waited 15 minutes. No rotating circular mouse pointer.

This typically means that the operating system is waiting for you to respond to a User Account Control prompt. The prompt is likely minimized to the Task Bar and needs to be clicked there. It pulses with an orange glow.

Can I send you the whole log?


This is not Support here. If you need to contact support, you can reach them at: support@whollygenes.com

#33 Virginia Blakelock

Virginia Blakelock
  • Moderators
  • 3,058 posts
  • Gender:Female
  • Location:Ohio

Posted 15 March 2012 - 06:49 AM

John -

You mentioned following Jim's steps in his 5 March message. I wonder if you found the later more detailed instructions (7 March, see quote below) for deleting remnants, including running existing uninstalls and checking the Virtual Store:

"You do not get install options when there is an existing installation (or perhaps a remnant program folder).

Run any uninstalls for TMG8 that exist in Programs and Features.

You need to delete all remnant program folders. (see below)

You also need to check the VirtualStore and make sure that there is not a program folder hidden there and delete any remnant program folder found there.
C:Usersuser account nameAppDataLocalVirtualStoreProgram Files (x86)The Master Genealogist v8

Then you should follow my procedure in post #5 in this topic and install v8.02.

%%%%%%%%%%

The default program folders are:

C:Program FilesThe Master Genealogist v8 - all users / 32-bit

C:Program Files (x86)The Master Genealogist v8 - all users / 64-bit

C:Usersuser account nameAppDataLocalProgramsThe Master Genealogist v8 - single user"

I apologize if you have already done the above needful - but those instructions have pretty much cleared the group of install problems that I have been following.

Virginia
Win7 Professional x64

#34 JohnR

JohnR
  • Senior Members
  • 176 posts
  • Gender:Male
  • Location:Chiddingfold, Surrey
  • Interests:Genealogy, rhododendrons, lepidoptera

Posted 15 March 2012 - 01:09 PM

A squeak from support today shortly followed by another, duplicate, but it didn't work (why I ever expected it to do so I don't know).


Please download and reinstall TMG V8.0 from this link

http://www.whollygen...mg8setup800.exe

Then do the following.

This process has worked for other users who have had similar problems to yours.


Uninstall TMG V8 from the Control Panel. If TMG V8 does not show up in the Control Panel close the Control Panel and continue with the next step.

Go to C:Program Files or C:Program Files (x86) OR if you did a custom install go to that location. Then delete any remnant The Master Genealogist V8 folder.


Then delete the installer folder at either of these two locations depending on your operating system.

C:ProgramDataThe Master Genealogist v8 Installer
or
C:Documents and SettingsAll UsersApplication DataThe Master Genealogist
v8 Installer


Download the 30 Day Free Trial of TMG from the www.whollygenes.com website.
SAVE that file to your computer. When the download completes right click on the file name (TMGV8setup.exe) and select RUN or double click on the file name to run it.

Install and be sure to use the same program folder that you used for the
current installation.


Enter your registration information if necessary.


Also... When some WinVista/Win7 users say nothing is happening, there is a UAC prompt minimized to the taskbar waiting for the user to respond.


#35 Jim Byram

Jim Byram
  • Moderators
  • 6,479 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 15 March 2012 - 06:06 PM

Pretty much as I wrote it in various pieces. <g>

The above post doesn't include the possible default single user installation paths to check for remnant program folders.

WinXp
C:Documents and Settingsname of user accountLocal SettingsApplication DataThe Master Genealogist v8
(I think this is right. Have no way to check.)

WinVista and later
C:Usersname of user accountAppDataLocalProgramsThe Master Genealogist v8

#36 Virginia Blakelock

Virginia Blakelock
  • Moderators
  • 3,058 posts
  • Gender:Female
  • Location:Ohio

Posted 15 March 2012 - 07:04 PM

John -

You mentioned receiving a 'squeak' from tech support but have not replied to my last message (#33 above), confirming you have checked each location. Were you able to locate the Virtual Store - and do you have Windows Explorer configured to show hidden files and folders so you are not overlooking a v8 file?

Virginia
Win7 Professional x64

#37 JohnR

JohnR
  • Senior Members
  • 176 posts
  • Gender:Male
  • Location:Chiddingfold, Surrey
  • Interests:Genealogy, rhododendrons, lepidoptera

Posted 16 March 2012 - 03:54 AM

John -

You mentioned receiving a 'squeak' from tech support but have not replied to my last message (#33 above), confirming you have checked each location. Were you able to locate the Virtual Store - and do you have Windows Explorer configured to show hidden files and folders so you are not overlooking a v8 file?

Virginia

Sorry, I didn't realize that you had written to me. I haven't a clue what a virtual store is - do you mean the TMG download site? Windows Explorer is using whatever its default settings are, I wouldn't know how to change them.
Is it safe to try and re-install 8.02 or is it still buggy?

#38 Virginia Blakelock

Virginia Blakelock
  • Moderators
  • 3,058 posts
  • Gender:Female
  • Location:Ohio

Posted 16 March 2012 - 04:10 AM

John -

The path to the Virtual store is in my message above. By default Windows Explorer hides some files and folders from the user. It is easy to change, depending on your operating system. Are you using WinXP? Win7? Vista?

I am using 8.02 and it is not buggy unless you use a lot of complicated Roles.

Virginia
Win7 Professional x64

#39 Jim Byram

Jim Byram
  • Moderators
  • 6,479 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 16 March 2012 - 07:28 AM

The VirtualStore path under WinVista and later also should be checked...

C:Usersuser account nameAppDataLocalVirtualStoreProgram Files (x86)The Master Genealogist v8

#40 JohnR

JohnR
  • Senior Members
  • 176 posts
  • Gender:Male
  • Location:Chiddingfold, Surrey
  • Interests:Genealogy, rhododendrons, lepidoptera

Posted 16 March 2012 - 11:18 AM

Thank you for your help. Somehow I found my copy of 8.00, installed that and then did an update to 8.02 from its Help.

I must apologise for being rude and unpleasant on this forum. I have been laid up with pneumonia for 10 days. I should be attending the funeral tomorrow of my last cousin of the previous generation who died at 96 but I am not well enough to make it. When TMG went belly-up it was the last straw.

John





Also tagged with one or more of these keywords: 8.02, install, rollback

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users