Jump to content


Photo

Follow-up problem merging 2 people (was wishlist "Verify details")


  • Please log in to reply
4 replies to this topic

#1 Helmut Leininger

Helmut Leininger
  • Senior Members
  • 263 posts
  • Gender:Male
  • Location:Vienna / Austria

Posted 02 May 2012 - 10:19 AM

Hi,

I had reported a bug (see below) which has been solved in TMG 8.03 (Thanks to Jim Byram!).

There are some annoyances still remaining:
1) After the Merge process, the events/tags merged in cannot be seen in the target persons's detail view until a Verify is run (restarting TMG does not help).

2) The verify reports "1 potential problem repaired" in the message box; but in the VFI log there are 0 errors (this repair is not reported in it).

However, as far as I have seen until now, there is no data loss any more.

Regards
Helmut

Scenario:You have 3 persons in you database.Person 1:Mary Smith, with name Variant Mary Johnson (married name oer alias name)Person 2:Maria NN, with name Variant Mary Johnson (same as for person 2)Person 3:John AnybodyPerson 2 is "attached" as witness to an event of person 3 (say Godmother at the birth of John Anybody) using the name variant Mry Johnson.Then, you decide person 1 and person 2 are the same and you merge them:"Main" is person 1 (Mary Smith), the second in the right window is person 2 (Maria NN). You do not take over the name variant "Mary Johnson" from Maria NN as this name already exists for person 21 (Mary Smith). But you take over the witness tag.The merge does not show any problem, but when you look at the witnesses for the birth of person 3 it looks somewhat strange: there is no name and the entry cannot be accessed.A subsequent verification "solves one potential problem" and the information about the witness is lost (no witness for the birth of person 3 any more).

Regards
Helmut

#2 Jim Byram

Jim Byram
  • Moderators
  • 6,692 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 02 May 2012 - 10:43 AM

I sent your comments to the developer who fixed this.

I didn't have the refresh issue that you describe when I tested the fix.

#3 Helmut Leininger

Helmut Leininger
  • Senior Members
  • 263 posts
  • Gender:Male
  • Location:Vienna / Austria

Posted 02 May 2012 - 11:19 AM

Thanks again Jim.

FYI: I am running Windows 7 64-bit, TMG 8.03 has been installed over 8.02 using the "Check for an update" feature. When I disovered this behaviour, I downloaded the TMG trial from Whollygenes and installed it using the "Repair". The isuue was still reproduceable with the Example project.

Regards
Helmut
Regards
Helmut

#4 Helmut Leininger

Helmut Leininger
  • Senior Members
  • 263 posts
  • Gender:Male
  • Location:Vienna / Austria

Posted 02 May 2012 - 12:47 PM

Hi,

Additional info:

the "associates" view is correct even if the details view is not.

Regards
Helmut
Regards
Helmut

#5 Jim Byram

Jim Byram
  • Moderators
  • 6,692 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 02 May 2012 - 01:47 PM

Helmut,

Now I understand what you are saying. Simple to replicate. I revised my bug submission.

It is fixed and tested and should be in v8.04.

Jim

Edited by Jim Byram, 02 May 2012 - 02:15 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users