Jump to content

Need help with Win8 upgrade issue

Recommended Posts

New Win8 Release Preview installed as a VM under Parallels 8 on Mac OS X 10.7.5.


Installed 8.0 and registered OK (with just sample database).

Downloaded latest version 8.04 from within the program, but the install failed with an error message I noticed in another thread here:

"There is a problem with this Windows installer package. A program run as part of the setup did not finish as expected"

In the end that failed upgrade left TMG8 uninstalled completely (at least, no program left to run...some remnants exist).

So I downloaded the demo and tried to install that...it failed (just hangs after selecting language and then getting to INSTALL button).


Hmmm ... is there any hope?


There is still a TMG V8 program folder under C:\Program Files (x86), but I have no way of deleting that directory.


Any advice gladly accepted!



Share this post

Link to post
Share on other sites

Colin -


See the pinned message "Re-installing TMG8" at the top of this (v8) forum for a list of the v8 files you will need to delete. The v8 installer will not install a second copy, so all remnants must be removed - including the program folder. What problem did you run into when trying to delete that folder?


When all remnants have been removed, Install the v8 trial version (always the current version) downloaded from the WG website, following the suggestions in the post Michael referred to for running TMG on a MAC.



Share this post

Link to post
Share on other sites

I think Virginia has hit at the gist of my issue:

C:Program Files (x86)The Master Genealogist v8

The above directory remains (empty, except for a "pdf" subfolder with an "install.log" file), and I cannot delete it.

The error message when trying is that "Access is denied."


I've tried some obvious and not-so-obvious things, but it does not work.

So I tried some more!


I did start by changing the folder owner from SYSTEM to myself (colin) (right click folder, click Properties, click Security tab, click Advanced button, click "Change" link beside owner name, add my name "colin", then click OK)

...but when I tried to propagate that ownership change down to all child objects (i.e. subfolder & file) via the checkbox to do this ("Replace all child object permission entries with inheritable permission entries from this object"), I get this error:

An error occurred while supplying security information to:

C:Program Files (x86)The Master Genealogist v8pdf

Failed to enumerate objects in container. Access is denied."


But then if I change the owner of each object in the directory tree one at a time and also give full permissions (to my own "colin" account), starting from the bottom, i.e. starting from the "install.log file, then following with "pdf" directory, then ending with "The Master Genealogist v8" directory, that seemed to work ... it seemed to successfully change ownership and permission.


Next, trying to delete the "The Master Genealogist v8", I still run into issues!

However, if do it bottom up, i.e. if I first delete install.log, then delete pdf directory, then delete "C:Program Files (x86)The Master Genealogist v8"...THAT finally worked!

OH MY GOD! How bad can Win8 really be? I mean...REALLY? How messed up!


Anyways, after all the above, I am finally allowed to install the demo 8.04 TMG OK!

Running the install program, all seems OK, and now I am running TMG 8.04! Yahoo.

There may be other remnants of the original install (although I didn't see any under my home dir, FYI), but they didn't cause a problem.


Now, I probably had a remnant somewhere with my serial number, because the demo 8.04 didn't ask me for it:

how can I tell if I have a fully functional unlocked non-demo install???



Share this post

Link to post
Share on other sites



Look at Help > About The Master Genealogist. It should say in the middle of the screen that opens:


Purchased by: your name

Email: your email

Serial No: a long serial number


If not registered, it will say something about a trial version.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now