Jump to content

Recommended Posts

Win7-64 TMG 9.03

SAMPLE-UK project

List of People Report - for all people on SAMPLE project

Screen Preview

Message Box "Program Error" content "Record is out of range" options Cancel Ignore Help

Choose option Ignore - the problem goes away and preview appears (instantly)



uninstall TMG and re-install TMG 9.03 from new download

AND remove & install PDF printer

AND reset Report options


Same error occurs on my production project


I can see that someone had same error on TMG 8, but no definite solution then.


Any new ideas please



Share this post

Link to post
Share on other sites

1. Un-installed 9.03 & PDF printer. 2. Installed with "Run as administrator" - Installed OK, Allowed it to "run TMG", provided purchase key etc., it opened SAMPLE project & installed PDF-printer all OK.

3. Tried running 9.03 as administrator, SAMPLE project, List of People report --> "Record is out of range" & "2558 CINTLSTRING.I --> only option that works is "Abort"

4. Shutdown Windows 7 & restarted.

5 TMG 9.03, on SAMPLE project, List of People report --> "Record is out of range" message, but "Ignore" option produces report in screen preview.



Error message is ONLY in Screen preview -- can produce PDF files & csv files without error.

Error appears for "List or People" also "List of Places" and "Distribution of People" -- does not appear connected to report or filtering



installing TMG 9.03 on 2nd desktop, which is 32bit Windows 7 Home Premium, SAMPLE project, List of People report, screen preview --> All works, no error message.



Edited by GatheringThreads

Share this post

Link to post
Share on other sites



On SAMPLE_UK_.PJC as delivered by install


VFI, Optimise, Initialize Repeat files, VFI -- Done


List of People report, Reset Defaults, Screen Preview, Create report --> 87 people --> error "Record is out of range" --> Ignore --> preview produced

List of People report, File type csv, file name x.csv, Create Report --> file written all OK, no message produced


I will attempt to install a NEW, CLEAN, VIRTUAL, machine using Win7-64 from delivery DVD and NO Microsoft updates & TMG9.03 -- but this will take a few hours



Share this post

Link to post
Share on other sites

John -


I suspect a machine re-install is an overkill. The problem is with TMG. Is the program installed to the default folders? Are these problems all with the Sample Project? Do you have a default physical printer attached to your computer? In the reports, check that the Surety settings are ticked for _both_ 'No Threshold' and 'Include blank surety'.



Share this post

Link to post
Share on other sites

If you are running a Parallels or Fusion Virtual Machine on a Mac before you spend all the time on a WIndows install and a TMG install change sharing settings to NOT share with Mac. At least the documents folder. Start TMG it will create a new set of user folders on the Windows side including a fresh sample project open it (be sure it's from the Windows side) and see what happens when you attempt the report. If that solves the problem you have two options, leave sharing turned off or use a data_paths.txt file.


See my article using TMG on a Mac


Share this post

Link to post
Share on other sites

Sorry about the slow response - life is getting in the way, and I'm going off air for the rest of September (I may be able to lurk )


To answer the questions above

I am NOT using any form of MAC/Apple - It's a Win-7 Professional 64 bit on a real AMD quad processor 8GB memory.

I use VMWARE Player to run virtual machines.


TMG is installed in the default folders -- "Program Files (x86)" - because it's a 64-bit CPU system.

The problem occurs both with my "production" project & with the SAMPLE_UK project. I quote the sample project as it is "as supplied", no updates or amendments by me.

Similarly the reports are "as supplied" and default settings against the sample database.


I have installed a new, clean WIN-7-64 virtual machine, with TMG 9.03 clean install - the error does not occur.

I have a real WIN-7-32 desktop, I test-installed TMG 9.03 - the error does not occur.


I have convinced myself that the only error situation is with WIN-7-64 PLUS recent windows updates !?!


When I return in October I will try to un-install the "recent" windows updates, to see what effect that has.


John www.gatheringthethreads.co.uk

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now