Jump to content


Photo

Source Type problem


  • Please log in to reply
9 replies to this topic

#1 ehindmar

ehindmar
  • Members
  • 4 posts

Posted 30 July 2015 - 05:35 AM

I saved a List of Sources in Excel format.  The Source Type in the spreadsheet is sometimes different than the Source Type on the Source Type Definition page.  Very weird!  For example, my Indiana 1860 Census source correctly shows a Source Type of "Census Images, Federal" in TMG, but in the spreadsheet for the Indiana 1860 Census it shows a Source Type of "Thesis".  I'm trying to test the RootsMagic direct import and got a lot of bad imports of Sources.  Now I'm thinking "No wonder" if TMG is confused about the Source Types.  I have tried changing the Source Type in TMG (via Select, select another type, OK, Select, select the original type, OK) as explained in the RM transfer document.  It still didn't correct the Source Type in the Excel report.  I'm worried.  Any suggestions? 



#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 30 July 2015 - 10:45 AM

I covered this in the RootsMagic import document. It is a very old (and basically hidden) problem with the TMG sources. You need to do this for every source that has a source type problem when imported to RootsMagic.

 

From the document...

Import can uncover hidden problems with TMG sources. If a source doesn't import  correctly, the problem likely is the TMG source. For example, in TMG, the source type  and the fields on the Source Definition / General tab don't match. In this case, select a  different source type and then reselect the original source type.  See Example A at  the end of this document. ​

 

Example A 
If a source doesn't import correctly, the problem likely is the TMG source.  

 

For example...     The source didn’t import correctly and the source type for the source was Book  (Compiled Records). The data in the source fields after import don’t match the source  type fields (and there can be missing source data).    

 

1. Open the project in TMG. 

2. Select Tools / Master Source List 

3. Select the source and click [Edit] 

4. The ‘Source Type’ is ‘Book (Complied records)’ 

5. Click [Source Type] and select the ‘Book (Authored) source type  6.

 

Click [Source Type] and select the ‘Book (Complied Records)’ source type.    

 

This will correct any synchronization problem between the TMG source and the TMG  source type.    

 

Edit any fields that are incorrect. (Fields that are in the selected source type will have  the field name starting with an uppercase letter. Fields that are not in the selected  source type will have the field name starting with a lowercase letter. Make sure that the  data is in the correct fields.)    

 

Do this for all sources that have this issue.    

 

Reimport to RootsMagic and see if the edits in TMG corrected the source import  problems. ​



#3 ehindmar

ehindmar
  • Members
  • 4 posts

Posted 30 July 2015 - 12:27 PM

I did this.  That's what I meant when I said:

 

"I have tried changing the Source Type in TMG (via Select, select another type, OK, Select, select the original type, OK) as explained in the RM transfer document.  It still didn't correct the Source Type in the Excel report."

 

It didn't correct the problem in either the Excel file or the Roots import.  I must have an additional problem?



#4 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 30 July 2015 - 12:48 PM

I still believe that the Excel report is showing the hidden problem of sources showing one source type but actually being linked to a different source type.

 

I'll take a look if you send me a project backup (project files, accents and filters only). You need to give me a few source examples to check.

 

You can contact me by clicking on the link below.

Jim Byram

 

If the project backup is too large to email, you'll need to make it available for download.

 

The only other possibility might be a language issue although I can't envision why. RM only imports the English (US) fields.



#5 djyontz

djyontz
  • Members
  • 5 posts

Posted 16 April 2016 - 07:13 AM

Hi Jim, 

We've been communicating on RM boards on this same issue.  I'm having the exact same problem as ehindmar.  I've changed source types to try to sync.  I've imported the whole list of source templates from a new, blank project (with BL prefix added to distinguish them).  I've changed my original source to one of the new BL source types.  That strategy works to a limited extent.  It at least assigns a source type to my sources for import into RM (as opposed to no source type with no fields). But it's still the wrong source type and information is missing.  A source of "BL-will..." type becomes a book source upon import to RM and the fields don't match.  Even a newly created freeform source type imports as a book.  There's something seriously wrong with my sources and I can't seem to sync the sources following the TMG import guide document from RM.  Did you find a solution to ehindmar's problem?  Maybe the same solution will work for me.

 

Thank you for your time.  - Dorie



#6 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 16 April 2016 - 08:35 AM

I don't know why the fix only works for some sources and not for others. I need some data to test this and pin the issue down.

 

Could you do the following...

 

Make a subset project by exporting a family (parents and children) who have tags using the problem sources. You do this using the option in the List of People on the Options / Secondary Output tab to copy the selected people to a new project. You can select the people to be copied in the Project Explorer or use those to make a focus group and copy the people listed in the focus group.

 

(If this is too complicated, you're going to have to send me a backup of your entire project.)

 

Import this test project to RM and see if you get the source/source type problem.

 

If you don't get the problem, you should try this approach with your entire project.

 

If you get the problem with the subset, you should send me a backup of the subset project (project files, accents, filters only in the backup) so that I can investigate the issue.

 

You can contact me by email by clicking on the link below...

Jim Byram



#7 djyontz

djyontz
  • Members
  • 5 posts

Posted 16 April 2016 - 11:30 AM

Wow!  At first glance, it looks like creating a focus group and making a new project (via secondary output in the list of people report) worked!  My sources came over correctly.  Why would creating a new project of a subset of people work?

 

The source problem seems to be an issue throughout my project, so I need to do this for everyone. I tried creating a blank project and importing my project into it, but at the RM import window, it still recognizes it as two separate sets of data.  The file still had the source problem when I tried this way. [one interesting thing to note:  my dataset had a note that it was originally imported in 2002 from UFT.  I don't remember that. My memory is that TMG has always been my program!  I think I must have used UFT for a couple of months before discovering TMG and moving to it.  I wonder if this is what caused the problems?]

 

I also tried to create a new project with everyone by going to Reports--> List of People and choosing "All people in the project" as the subject of the report instead of the focus group.  The new project created this way still had source issues, so there seems to be something special about going through the focus group.  Does this make sense????

 

How do i get the entire list of people loaded to a focus group?  I know only how to add them individually!



#8 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 16 April 2016 - 03:49 PM

I suggested doing this earlier on the RM forum.

 

You use the same procedure with the List of People and select 'All people in the project' rather than focus group.

 

You then import the new project into RootsMagic.

 

In my project, sources created during a period (of a couple of years?) had this issue. Sources created before and after this window had no problem. Some bug happened in TMG and then it took a period of time before it was fixed.



#9 djyontz

djyontz
  • Members
  • 5 posts

Posted 16 April 2016 - 06:30 PM

Thanks for all the help, Jim.  I'm going to have to brute force it.  A small group of people in the focus window imports fine but a large focus group (my small group + their descendants & ancestors) still has the broken sources.  And the "all people" option also transfers with broken sources.  I don't understand why that happens, but it does.  



#10 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 16 April 2016 - 07:04 PM

That actually was my experience when I tested the LoP method. It didn't work for all people.

 

If you send me a backup, I can take a look and see if I can pin this down.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users