Jump to content


Photo

Memo file ____L.FPT is missing or is invalid


  • Please log in to reply
2 replies to this topic

#1 Sean

Sean
  • Members
  • 4 posts

Posted 05 January 2017 - 10:00 AM

Hi,

 

I am a long time TMG user but as of recently I am receiving an error I can't seem to fix. I am trying to create a report of a List of Tasks. When I go to the menu bar and click Report > List of ... > Tasks and click the "Create Report" button I get this error:

 

"Memo file c:\Users\Mike\Desktop\TMG BACKUP\Projects\OCEARBHAIL_L.FPT is missing or is invalid.

 

When I click "Cancel" or "Ignore" on the error dialogue box, another box comes up saying "Unknown member ROPROTECTIONMAN" and I have to use Task Manger to force quit TMG.

 

I have tried Reindexing and Optimizing the project files in the Maintenance menu with no luck. I have also tried rolling back that specific file to an earlier version, but it only made matters worse. It seems that the memo file is somehow corrupt.

 

Is there anyone who knows how to repair a corrupted FPT file? Any help is appreciated. This project is over 10 years old and I'd hate to lose any of my work!


Edited by Sean, 05 January 2017 - 10:01 AM.


#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 05 January 2017 - 02:27 PM

The only thing that you appear to be in danger of losing is some task data.

 

The first thing to do is to try backups  and see if a backup has an intact task data table memo file. If that's the case, you can copy the ...L_.dbf and ..L_.fpt files from the older project version to the current project and replace the damaged data.

 

You can restore the older backups to a new subfolder of the projects folder so that you don't disturb the current project.

 

You can also send me the ...L_.dbf and ..L_.fpt files from the current project and I'll try to repair the .FPT file. If you have many tasks, it's going to be very difficult to find the damaged memo.

 

You can contact me by email by clicking on the link below...

Jim Byram



#3 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 05 January 2017 - 05:47 PM

I did routine maintenance on the task table and memo file with database tools and that appears to have resolved the memo file issue.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users