Jump to content

Recommended Posts

I'm using version 7.04 under Windows XP. All of a sudden TMG software won't load. The problem "title" says "tmg7.exe failed to locate component", and the description of the problem is "this application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix this problem."


It happens whether I select a shortcut or the program menu. I did virus and spyware scans in case there was something malicious going on, but nothing of note was detected.


I tried a "simple solution" by pretending to upgrade to my current version, hoping the missing file would be replaced, but this didn't solve it. I bought version 7 so long ago now that I can't find the original software to re-install (and I didn't want to in case my project disappeared, as i haven't backed up for about a week).


My computer has plenty (26 in all) of files with the name msvcr71.dll but none appear to be in TMG related directories/folders.


Is there an easy "fix" for this anyone please ? ( I can post a picture of the message if it helps)









Peter, Australia


[see the post below for the solution.]

Share this post

Link to post
Share on other sites

*** SOLUTION ***


We don't seem to have beta testers who have encountered this problem so I've uploaded a copy of MSVCR71.DLL and am asking for volunteers to download, unzip, and copy it to your program folder (the location of tmg7.exe) to confirm that it solves the problem.


If you aren't feeling adventuresome, you might want to just want a while longer until we get affirmative responses from others who have tested it.


The download is http://www.whollygenes.com/files/msvcr71.zip




*** SOLUTION ***

Share this post

Link to post
Share on other sites

The error means that TMG can no longer locate the required file. This problem was caused by some application deleting or changing the msvcr71.dll file that was located in the system32 (or SysWOW64) folder. It could have happened because of a program install or update or a definition update by an anti-virus or anti-malware program.


I've removed all previous extraneous replies to this topic so that users can find the solution immediately without having to wade through discussion that doesn't help them.


Please make no further replies to this topic other than to say that the solution in the post above worked or didn't work. The solution appears to have worked successfully for a dozen or more users at this point.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now