Jump to content

Recommended Posts

A friend of mine asked me to convert his database to TMG so that he can build a website with Second Site. The database contains 145,000 persons, and is remarkably clean, but contains many lengthy and informative research notes. TMG 8 spent about 20 seconds looking at the PAF and locked up. Importing the gedcom failed also, apparently because of the lengthy notes--the program quit when the project file exceeded 2 gb. Then I purchased FTM 2012, which cheerfully imported the PAF, with few warnings. I then exported the project file in FTM 2008/2009 Backup format. After unpacking that file, TMG 8.0 exclaimed "Error opening file C:\ . . . External dynamic-link library returns error "-4", VistaDB Level 1 Error 80040154h: Class not registered


Any suggestions? This is a fine database that deserves its own Second Site website, I would hate to see it picked to death on Ancestry.com.


Al Field

Share this post

Link to post
Share on other sites



you apparently still use TMGv 8.00, correct?


If so, there existed an issue in that TMG version regarding FTM2008/2009 imports since the installer didn’t register a certain, required *.DLL file in the TMG8 program folder which resulted in the exact error condition you describe above.


That issue was fixed and since TMGv 8.00 is pretty outdated by now, my recommendation is to upgrade to the current version TMG v 8.04 and you'll not run into this FTM2008/2009 import issue anymore.




Regarding the GEDCOM import....


When you open the GEDCOM file in a pure text editor (not WORD for instance) - like i.e. Notepad- and look at it's beginning you'll notice a line: 1 CHAR .... - the character set being used.


Is this set to ANSI ?

Edited by Vera Nagel
added text

Share this post

Link to post
Share on other sites

The PAF import should be tried from the Welcome screen and not from the File menu. It might still fail because of memory limits.


Any GEDCOM export from PAF should use the GEDCOM 5.5 selection and set the character set to ANSI. The GEDCOM needs to be imported using the Advanced Wizard so that you can assign custom TMG tag types to the unknown, custom and Event-Misc GEDCOM tags.


And as Vera says, TMG must be installed and working correctly. And should be the latest version.


(If you have TMG7 running, you might try that instead.)

Share this post

Link to post
Share on other sites

Installing 8.04 eliminated the database error, but after importing 18% of 145,000 names in the FTM 2008 file, the program stopped. I recreated the FTM file and attempted to import it with identical results. The PAF import failed immediately, as with 8.00.


The gedcom file set the language to ANSEL, so I changed that to ANSI. The simple wizard import of the gedcom got to the point that the project file exceeded 2.0 gb faster. During processing there were frequent messages beginning with "expanding . . .," for example, "expanding for extra high level numbers," and "expanding for extra long pointers." Then I used the advanced wizard and picked the "bare bones import," which worked. That stripped out all of the comment/note fields, but now he can see what the Second Site files look like.


Thanks so much for all of the insightful comments.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now