Jump to content

TMG 8.06 very very slow

Recommended Posts

I have been doing a bit of testing since installing TMG 8.06.

First I recently purchase a brand new laptop (HP Envy DV7-7373CA, 12GB RAM, Windows 8) and I am using TMG in French.

TMG 8.04 was running at an extremely acceptable speed, the upgrade to TMG 8.05 went without a hitch and again ran at a very acceptable speed. Much much faster than on my older clunker.

The upgrade to TMG 8.06 was difficult. I ended up uninstalling TMG 8.05 altogether and re-installing from scratch TMG 8.06. Then the problems began.

Launching TMG 8.06 takes 9 minutes 51 seconds. At the 8 minutes 35 seconds mark, a "please wait" message appears, then over a minute later, it finally launches.

After noticing some issues with some of my census tags, I did a bit more testing...

Thinking that it might be an issue with custom tags & roles, I opened the "Master Tag Type List", I selected on my custom tags "Residence at death", clicked "Edit". Selected the "Roles and Sentences" tab, click "New" and called it "Testing 123" and assign "[P] and [PO] are testing this tag" as the Male sentence structure, then clicked "OK". It took 1 minute and 45 seconds to return to the "Master Tag Type List".

I tried a similar test on standard tag (birth tag) and I got similar results.

Since many people had reported issues with AVG when they installed TMG 8.05. I removed it completely from my system and activates Windows Defender for the time being.

Share this post

Link to post
Share on other sites

Whatever the problem is, it's a system issue and not a TMG issue. There is no change between v8.05 and v8.06 that would make any performance difference. And if this were a TMG issue, many or all users would be experiencing this and that's not the case.

Share this post

Link to post
Share on other sites

I have a complete backup of my data and configuration.


Once again, I completely removed TMG using your instructions and deleted everything including the configuraiton folders (DocumentsThe Master Genealogist v8 and all subfolders), then re-installed with a fresh download.


I then tried to open the sample project and it open almost instantly. I then tried to open my project and once again the long delay is back.


Looks like there is an issue with my project.

Share this post

Link to post
Share on other sites

Sorry Susan,


I have not been able to determine the source of my issues. I just know that something that I have done at one point corrupted my database. After Jim tried to fixed it, I simply restored my project at a time where I knew that it working correctly and re-entered all of the lost data.


Since then, this issue has reappeared once again, but instead of fighting with it. I restored the last good backup and continued on. Good thing that I backup my data at the end of every session.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now