Jump to content
tmalek

Loading TMG - no photos loaded

Recommended Posts

1. Clicked on the TMG icon.

Received the following message:

OLE error code 0x80040154: Class not registered.           48
TMGAPPOBJ.DOFORM

2. I clicked on "Ignore"

Received the following message:

Array dimensions are invalid.          1
TBRLAYOUT/CHKWITNESSES.MUPDATE

3. I clicked on "Ignore"

TMG data loads but there were no photos

 

What happened? How do I fix it?

Share this post


Link to post
Share on other sites

Tom,

When you get a program error, stop, record the error or take a screenshot, and close whatever you are doing. Clicking Ignore and proceeding accomplishes nothing.

If there is anything about the fix that I'm suggesting below that you don't understand, ask before proceeding.

OLE error code 0x80040154: Class not registered - This usually happens because a file cdintf400.dll is not registered.

Try this. You need to run the Command Prompt as administrator and register the .dll.

1) Run File Explorer and navigate to C:\Windows\System32 and select cmd.exe and right-click on it and select 'Run as administrator'.
3) type: "cd \windows\syswow64" (as always, no quotes) (or "cd \windows\system32" for a 32-bit system) and press enter.
4) type: "regsvr32 cdintf400.dll /u" and press enter. You should get a message that it succeeded.
5) press the up arrow and the previous line should be repeated. Hit <Backspace> twice to remove the "/u"
(or type "regsvr32 cdintf400.dll" from scratch) and press enter. You should get another message that it succeeded.
6) Type "Exit" and press Enter to close the window (or click on the X if that works)

Now try to run TMG and see if that fixed the issue.

Jim

Share this post


Link to post
Share on other sites

Jim - followed the above procedure and then ran TMG but it came up with the same error message. Tried it a second time with the same results. Restarted the computer and ran TMG. Same error message.

Thanks for trying to help.

Tom Malek

Share this post


Link to post
Share on other sites

Tom,

All that I can suggest...

1) Run the installer and select repair.

If that doesn't work...

2) Uninstall TMG, delete the TMG9 program folder ("C:\Program Files (x86)\The Master Genealogist v9"), and then reinstall.

Uninstalling and reinstalling will have no effect on your TMG data.

In both cases above, the controls and .DLLs are reregistered. and that should fix the issue.

 

Share this post


Link to post
Share on other sites

Thanks Jim.
Dennis Bieber earlier recommended using "repair". That did not work.
Will do uninstall/reinstall.
Can't seem to find my TMG CD disk. Is three a site where I can download a copy?
Thanks.
Tom

Share this post


Link to post
Share on other sites

Thanks, Jim. Appreciate the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×