Jump to content


Photo

OLE error code 0x80040154:Class not registered.


  • Please log in to reply
8 replies to this topic

#1 Mark D

Mark D
  • Members
  • 1 posts

Posted 27 December 2011 - 05:29 AM

I have been on version 7 for some time waiting to create reports when version 8 comes out.

I installed version 8 from a download, and when I try to produce some reports (the one I used was, list of people), I get an Program Error (OLE error code 0x80040154:Class not registered.) and no report.

I am running windows 7 64 bit. I have reinstalled version 8 multiple times. I have even gone back and reinstalled version 7 and then version 8, to see if it was something that it needed from that version.

#2 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 27 December 2011 - 08:00 AM

Please contact Support and they will walk you through the fix.

#3 DonFM

DonFM
  • NewMembers
  • 9 posts

Posted 29 December 2011 - 12:59 AM

I have the same problem, affecting some of the report generation (Ahnentafel Direct Line for instance). Looks like it's caused by a missing dll, cdintf-1.dll. In my case this was a clean install on a new Windows 64 bit system, and it was the download version of TMG8 installed. I have contacted support but no reply as yet.

Thought I'd post this as there must be a lot of other people out there with the same problem, so a published fix might be helpful for all, maybe?

#4 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 29 December 2011 - 06:45 AM

The issue is a DLL used by the PDF driver not being properly registered. How the procedure for fixing that gets conveyed to users is up to Wholly Genes.

Reports should work fine when output to Word or RTF files. The problem is expressed when the report is output to screen, printer or PDF.

#5 hughes5ca

hughes5ca
  • Members
  • 1 posts
  • Location:96101

Posted 08 January 2012 - 12:25 AM

I too am having this same problem. I have written to "Support", but have received no response. Could someone please publish the fix here in the absence of support from "Support".

#6 Loni Fuller

Loni Fuller
  • Members
  • 6 posts
  • Gender:Female

Posted 08 January 2012 - 06:39 AM

All of my report formats are working wonderfully, and I love the improvements to the report writer, except I too am having problems with .pdf reports on 2 different computers,

My laptop running Windows 7 64 bit (message:
"The module 'cdintf400.dll/u' failed to load. Make sure the binary is stored at the specified path or debug it to check it for problems with the binary or dependent .DLL files. The specified module could not be found".

And on my desktop running Windows 7 32 bit: "OLE error code 0x80040154: Class not registered."

I have been in touch with technical support, back and forth. They just asked for trouble reports, so I know they are working with it.

I am sure they are buried with all the bits 'n pieces of problems that a new version of TMG creates.

If there is a fix out there, I would love to have it as well.

Edited by Loni Fuller, 08 January 2012 - 06:51 AM.


#7 Liliana

Liliana
  • Members
  • 10 posts
  • Gender:Female
  • Location:Sweden
  • Interests:Genealogy, history, computers...

Posted 11 January 2012 - 10:52 AM

I did run the file pdfinstall.exe from C:\Program Files (x86)\The Master Genealogistv8\pdf.
I got this tip from Support.
BR
Liliana

#8 Loni Fuller

Loni Fuller
  • Members
  • 6 posts
  • Gender:Female

Posted 11 January 2012 - 01:34 PM

Thanks Liliana. I have done this as well on both computers, as well as the other published fix with the "cmd" fix which has been sent to me and published on the RootsWeb TMG list as well.

I haven't heard back from Support since I sent them the requested Trouble Reports, but I know that they are snowed and since I can do my reports in Word I am willing to be patient ...

#9 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 15 January 2012 - 10:24 AM

See my fix in this topic.
http://www.whollygen...showtopic=14260




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users