Jump to content

Recommended Posts

I was working on my main project as usual today when TMG quit. I did not notice immediately as I was switching to another open program for a moment.  So, when I decided to go back to TMG, it wasn’t there.  This has happened in the past and I just re-started it and rain the Maintenance routine to check that all was OK.

This time, on restart, it flashed a message saying that a file was missing.  I must have hit a key or something as the message went away quickly.  My memory of the quick view was that one of the Name files was missing.  I opened File Manager and saw that all the six Name files (other than the index files) were present.  So, I again re-started TMG to get the message that the “Project is already open elsewhere”. 

Now, that is all I get.  I can open other projects.  If I open another project, exit, and re-start then all appears file.  If I try opening my main project, I get the message “An error happened when opening the data tables…”  Clicking [OK] closes the program.  Re-start now tells me that it is operating in Repair Mode.  Opening SAMPLE and exiting and restarting gives the normal operation until I try opening my main project again.

Looking at the four Name files in a DB program does not show anything.  That is, they all appear as I might expect them.  However, I could be missing something as I am not _that_ familiar with the file structure of each file.  I did note something with my NPT.DBF file that seems odd.  It gives the Template, ID, and Value as expected – except that there are eleven lines with lines 10 and 11 having the same Template and Value (Maiden Name).  Comparing this with other projects, they only show nine lines. 

I do not recall that I might have created a Custom Name template although looking at the ST table, I see two Marr Name Style Stylenames with the same display – both including Maiden Name].  I don’t know that this is what caused the problem although I can see that it might.

Anyhow, my SOP is to do a quick Backup (Project only) following each session or end-of day.  I do a full Backup every few weeks.  I looked to Restore my latest Backup to only find no quick Backups and only my full backups (3 weeks ago).  I have a bunch of quick backups from v4x, but those are years old and not much help now.  <Arrghh>

Any ideas?


Share this post

Link to post
Share on other sites

Sometimes, TMG doesn't close when you exit. This might account for the 'in use elsewhere' message. KIll the running process or do a Windows restart.


other issue...

Try running TMG once as admin and then exiting. Now try running TMG normally.

Share this post

Link to post
Share on other sites

OK, re-booted & started TMG as administrator. SAMPLE project cane up w/o problem. Exited, and re-started as normal, selected my main project only to get “An error happened when opening the data tables.…”   Clicked [OK] & TMG exited.

Tried running as administrator again, and got the “Repair node has been activated…" message.  Clicked [OK] and TMG came up to the welcome screen as usual. (Last project was greyed out).  Selected my main project, and still got the “An error happened when opening the data tables.…”

Tried selecting {Repair] from the Install program.  Started as Admin and entered license data, exited and re-started.  Selected my main program and still got “An error happened when opening the data tables…”

I still think one of the (Name?) tables is screwed up.  But can’t figure which.

Share this post

Link to post
Share on other sites

If you don't get an error message identifying the damaged database table, I need to see your project for testing.

Update... 11 tables had damaged headers.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now