Jump to content


Photo

Export to GEDCOM very unreliable


  • Please log in to reply
10 replies to this topic

#1 Helmut Leininger

Helmut Leininger
  • Senior Members
  • 263 posts
  • Gender:Male
  • Location:Vienna / Austria

Posted 29 December 2011 - 02:08 AM

Hi,

I have tried several times to export my databse to GEDCOM. But it is like gambling.

I tried to export "all individuals". It starts saying exporting 13625 people.
First try:
No error message, the resulting GEDCOM file contained only 11997 INDI records (= people)

Second Try:
I got an error message like this one:
File Access is denied [..TEMP....\tmgnnnnnn\_file_e.fpt
4397
MSUBSTITUTION_E

I clicked on Wiederholen (Repeat) and got 6873 individuals.

Third Try (Antivirus switched off):
Result seems to be ok.

For sure, I always used the same settings.

A week ago, I had also tried with less people (applying a filter, using focus groups). Several tries, always using the same paramaters, no error messages but every time a different number of people in the resulting GEDCOM file.
Regards
Helmut

#2 Vera Nagel

Vera Nagel
  • Moderators
  • 1,535 posts
  • Gender:Female
  • Location:Bevern, Lower Saxony, Germany

Posted 28 January 2012 - 02:34 AM

Just for the records: issue was apparently caused by the "Free Home Edition" of the third party program "Undeluxe 1.03" running while TMG's Gedcom export ran.

Thanks again Helmut for all of your help to track this down.
Thanks, Vera

Moderator of the German TMG User Group

#3 GenerationGoneBy

GenerationGoneBy
  • Senior Members
  • 887 posts
  • Gender:Female

Posted 28 January 2012 - 02:45 AM

Vera,
Is there a way a moderator could change this topic title, to something like Export to Gedcom-Issue Solved? That way those of use reading the topics can tell at a glance this is not an issue with TMG.

Thanks, Teresa

#4 Ular

Ular
  • Members
  • 2 posts

Posted 19 February 2012 - 10:32 AM

I would like to reopen this case. Today I tried to make an export of all persons (ca 51000) and it gave me similar errors as mentioned above. In my case it was antivirus (MS security essentials). Although I was able to make the export if antivirus was turned off, I wouldn't say it is normal to turn off antivirus every time I make an export. I am 100% sure that it worked in v7 with same computer configuration.

br. Ular

#5 tmilligan

tmilligan
  • Members
  • 7 posts
  • Gender:Male
  • Location:Westlake Village, CA.

Posted 24 February 2012 - 09:28 AM

I'm having the same problems with exporting my data to a gedcom. I've been exporting without any issues until this morning. This morning, similar error message as others; "File Access is denied [..TEMP....tmgnnnnnn_file_e.fpt 4397MSUBSTITUTION_E".

me thinks something has happened with TMG but, I'm going try some other things first. System restore to previous state.... disabling antivirus would be my last resort as I have not seen this problem before this morning.
Tracey

#6 tmilligan

tmilligan
  • Members
  • 7 posts
  • Gender:Male
  • Location:Westlake Village, CA.

Posted 24 February 2012 - 07:09 PM

removed TMG8, did a new, clean install of TMG8, upgraded to 8.0.1, disabled antivirus, still not able to export database to gedcom. Getting same errors and resulting file is corrupted, 1/4 size of a known good gedcom file. Next step will be to go back to v.7 and see from there. V. 8 was working just fine for a month or so.

Tracey

#7 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 25 February 2012 - 08:09 AM

Note that these issues are coming from outside of TMG as Vera pointed out in her post above. You should take these issues to Support who will accumulate the collective experience of users who resolve this and will have better suggestions than can be provided here.

#8 tmilligan

tmilligan
  • Members
  • 7 posts
  • Gender:Male
  • Location:Westlake Village, CA.

Posted 06 March 2012 - 01:57 PM

Note that these issues are coming from outside of TMG as Vera pointed out in her post above. You should take these issues to Support who will accumulate the collective experience of users who resolve this and will have better suggestions than can be provided here.

upgrading to 8.02.000 fixed my export to gedcom problems.

#9 rossbus

rossbus
  • Members
  • 4 posts

Posted 10 July 2012 - 03:14 AM

I have found the export to Gedcom does not work on my large database (45,417 persons, 137,823 events, 284,979 citations, 1288 sources). The program acts like it is exporting the file and does create a gedcom file. The problem is the resulting gedcom file is useless. My most recent attempt created a file with only 17,420 person each without parents, spouse and children. The same computer is able to successully create a gedcom for a smaller database (9,513 persons). I have run all the maintenace options (reindexing, optimizing & validating the file integrity) several times since the problem started (also ran these periodically multiple times per year for several years). I have also uninstalled and reinstalled the program (version 8.04). TMG is able to produce reports showing the relationships that are missing in the gedcom.

#10 Jim Byram

Jim Byram
  • Moderators
  • 7,340 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 10 July 2012 - 11:22 AM

One of the reasons recently found for this is having the project located in a DropBox folder. (which is a bad practice) Removing the project from the DropBox folder resolved the issue.

The basic issue is that some 3rd party application is interfering with TMG using its project files.

#11 rossbus

rossbus
  • Members
  • 4 posts

Posted 15 July 2012 - 12:02 PM

I did have the project in the Public Documents folder and was using Memeo to backup the Public Documents Folder. I uninstalled TMG, deleted the folders that had been created by the previous installation, reinstalled TMG 8.01 from the CD using the default path, made sure Memeo is not backing up the project folder and restored the projcect from a backup. I now get an error message when trying to create a gedcom. "File access denied. c:usersownerappdatalocaltemptmg32698252file_e.cdx 4427 M_SUBSTITUTION_E"

Also program will not update to version 8.04. running the update reports the program is up to date. About TMG on the help menu reports version 8.01 installed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users