Jump to content

Recommended Posts

Hi

I have several thousand exhibits in my TMG database

When I do a backup I find that 12 exhibits can not be found

When I study the log I see that this refers to only 2 unique exhibits which have multiple references - (Census images)

Is there any way in which I can ascertain which individuals have these missing images ?

Bob Matthews

Dunedin

New Zealand
 

Share this post


Link to post
Share on other sites

Bob,

You mention that the exhibits were not found during a backup.  Are you really including your "several thousand" image exhibits within the TMG backup?  Almost everyone will encourage you to have your image exhibits at "external" exhibits, and to NOT include them within the TMG backup.  These are much better handled by separately backing up the exhibits folder using some Windows backup facility.

Michael

Share this post


Link to post
Share on other sites

Just moved TMG v9 to a new computer. All seemed to be OK.

When backing up TMG v9, I am now seeing that 4 external exhibits are not found. Checked the backup log file then went to each instance of the exhibit file. Ensured that each exhibit file was properly pointing to the JPG file. Still got these 5 errors. Went back and tried to LOAD the exhibit files again. Still get the error. Finally I went into each of the file instances and DELETED each reference to the exhibit file, then redid them from scratch. STILL getting these errors .

My exhibit files are not stored in a single Exhibits folder as TMG wants. Instead, I have folders for each of the people in my data base where I store the pictures I use as exhibit files. 

I downloaded the TMG utility and used it to look at this but have not used it to actually FIX anything. NOT sure how to do that.

Here is the top part of my backup log file that shows the errors:

04-12-2018, 10:39:30 * TMG v 9.05.0000 ********************************************************************************
04-12-2018, 10:39:30 >OS - Windows 6.02, 6
04-12-2018, 10:39:31 >Backup file - C:\Genealogy\Backup\Projects\SchreinerFamily 2018-12-04 10-39-29.sqz
*********************
*  Missed Exhibits  *
*********************
image >8        - C:\Documents and Settings\ralphyost.RALPH\My Documents\The Master Genealogist v7\Exhibits\CharlesYost.jpg
image >12       - C:\Documents and Settings\ralphyost.RALPH\My Documents\The Master Genealogist v7\Exhibits\Charles&JamesYosJul3,1932.jpg
image >9        - c:\Program Files\The Master Genealogist\pics\Yost\LorraineBAccardiYost.jpg
image >13       - c:\Program Files\The Master Genealogist\pics\Yost\JamesCYost.jpg
********************************************
* Not found 4 exhibit files.

I greatly appreciate your help !

thanks

R.

 

Share this post


Link to post
Share on other sites

You see how the paths differ?

C:\Documents and Settings\ralphyost.RALPH\My Documents\The Master Genealogist v7\Exhibits\

c:\Program Files\The Master Genealogist\pics\Yost\

Exhibits should never be located in the program folder.

Move any exhibits in the program folder to the TMG exhibits folder.

Then use the external exhibits feature of Validate File Integrity to update the exhibit paths.

Share this post


Link to post
Share on other sites

Hi Jim

I agree. But my problem is that the files it is looking for in those locations do not exist there. And in TMG, when I look at the path of the exhibit files for JamesYost, (and the others) there are no exhibits pointing to those file locations. I am not currently using a file named JamesCYost.jpg  for example.

Somehow TMG has these erroneous paths and keeps trying to use them.

Share this post


Link to post
Share on other sites

Here are the two people with these exhibit location errors (my mother and father):

http://www.theyosts.net/genealogy/Schreiner/p8.htm#i222

http://www.theyosts.net/genealogy/Schreiner/p10.htm#i300

The two exhibit pictures of James Yost are located here:

 IMAGE
************************
External image file
Full name: c:\Genealogy\YOST\JacobJostSr_Momper\BarbaraMomper\MathiasJost\JohannJost_Willet\FrankYost_Nye\CharlesAYost\JamesCYost_Accardi\JimYostAug21,2014.jpg
18,957 bytes,   08 Sep 2018 13:26:48
Format 180x254x24
Exif file containing a JPEG compressed image and YUV 4:1:1 color space.

IMAGE
************************
External image file
Full name: C:\Genealogy\YOST\JacobJostSr_Momper\BarbaraMomper\MathiasJost\JohannJost_Willet\FrankYost_Nye\CharlesAYost\JamesCYost_Accardi\YostFamilyPortraitAug21,2014.jpg
56,496 bytes,   08 Sep 2018 13:25:48
Format 640x960x24
JPEG File Interchange Format with YUV 4:1:1 color space.

The exhibit file for Lorraine Barbara Accardi Yost is located here (same folder as James Yost):

IMAGE
************************
External image file
Full name: C:\Genealogy\YOST\JacobJostSr_Momper\BarbaraMomper\MathiasJost\JohannJost_Willet\FrankYost_Nye\CharlesAYost\JamesCYost_Accardi\LorraineBAccardiYost.jpg
8,256 bytes,   16 Apr 2006 20:45:26
Format 120x195x24
JPEG File Interchange Format with YUV 4:1:1 color space.

I do not have any exhibits in TMG calling for the ones showing up in the error logs........hence my question.

thanks

R.

Share this post


Link to post
Share on other sites

The third person, Charles Yost, is my grandfather. Here are the exhibit pictures for him:

http://www.theyosts.net/genealogy/Schreiner/p2.htm#i34

here is where TMG is currently pointing to those exhibit files

IMAGE
************************
External image file
Full name: c:\Genealogy\YOST\JacobJostSr_Momper\BarbaraMomper\MathiasJost\JohannJost_Willet\FrankYost_Nye\CharlesAYost\CharlesYost.jpg
6,516 bytes,   27 Dec 2004 19:25:46
Format 238x303x24
JPEG File Interchange Format with YUV 4:1:1 color space.

IMAGE
************************
External image file
Full name: c:\Genealogy\YOST\JacobJostSr_Momper\BarbaraMomper\MathiasJost\JohannJost_Willet\FrankYost_Nye\CharlesAYost\Charles&JamesYosJul3,1932.jpg
53,699 bytes,   02 Dec 2009 20:16:42
Format 576x800x24
Exif file containing a JPEG compressed image and YUV 4:1:1 color space.
 

All of these exhibit files are being processed correctly except that TMG thinks there are others with a bad file location specified. I am not telling TMG to look at the two locations that come up as errors:

image >8        - C:\Documents and Settings\ralphyost.RALPH\My Documents\The Master Genealogist v7\Exhibits\CharlesYost.jpg
image >12       - C:\Documents and Settings\ralphyost.RALPH\My Documents\The Master Genealogist v7\Exhibits\Charles&JamesYosJul3,1932.jpg

thanks for your help,

R.

 

Share this post


Link to post
Share on other sites

Ralph,

I can remove those four records from your exhibits table if you wish. I need the name of the linked persons and the path of the four exhibits in order to locate them. You would need to send me the __I.dbf and the __I.fpt files (letter eye).

You can contact me by email by clicking on the link below...

Jim Byram

Share this post


Link to post
Share on other sites

Jim

I have a similar problem with about 25  exhibits that have been driving me crazy for over 20 years.  I can't even tell for sure who the exibit person is because they have  been shortened,  having been with me since the time when Windows file names were limited in the number of characters allowed.  I do recognize a few of the exhibits, and have chased them down with no kind of fix that I can see.  They refer to a drive that was on a computer long since gone.  If your fix for Ralph works, I would very much appreciate trying the same with my files.

I asked the same question back in 2014.  My exhibits have always been in an external folder, and I've done file integrity.  Nothing helps.

Thanks....Art Brown

Share this post


Link to post
Share on other sites

I have had it happened several times and found a pattern. When I have exhibits for people but change the folder name, TMG cant find the exhibit and I get the exhibit error.

I do not put all of my exhibit pics into the single Exhibits folder that TMG suggests. If I did then this error would never occur. I have too many people in my data base to do that. I point TMG to the exhibit pictures in my folders which are specific to each person. My person folders are laddered according to the family relationship. In this case I have to go back to each exhibit in the renamed folder ladder and re-establish the link properly. After the link is established properly the error is gone.

The Exhibit errors that I received that really gets me is this one, which returns:

c:\Program Files\The Master Genealogist\pics\Yost\LorraineBAccardiYost.jpg

I never place exhibit files in c:\Program Files\The Master Genealogist\pics\  so I dont know why it points to that erroneous location. I am now getting this error all the time and it had been fixed once about a month or so ago!!

I do not have a folder c:\Program Files\The Master Genealogist  so I dont know why TMG thinks this exists.

*  Missed Exhibits  *
*********************
image >9        - c:\Program Files\The Master Genealogist\pics\Yost\LorraineBAccardiYost.jpg
********************************************
* Not found one exhibit file.
********************************************

 

R.

Share this post


Link to post
Share on other sites

Ralph,

TMG (for Windows) v6 and earlier stored the exhibits in c:\Program Files\The Master Genealogist\pics when installed on 32-bit Windows. The TMG program folder name varies depending on the TMG version. Your exhibit record would appear to be a remnant of such an earlier TMG version.

Validate File Integrity (VFI) has the tools to deal with multiple image folders and exhibit trees and can relink all exhibits when relocating exhibit folders. The only requirement is that each image file has a unique name. VFI can't relink image files in an exhibit tree if images of the same name are identified by different folder names.

For example... one image tree. The path of the base folder must be entered into the location table and then you need to click the [Search in subfolders] button.

Jim

 

Share this post


Link to post
Share on other sites

Art,

I can delete the exhibit records. Follow my directions above. A copy of the Last VFI.log with the missing exhibits might also help.

Jim

 

Share this post


Link to post
Share on other sites
15 minutes ago, Jim Byram said:

Ralph,

TMG 5 and  6 running under Windows XP stored the exhibits in  c:\Program Files\The Master Genealogist (v5 or v6?)\pics. This would appear to be a remnant of that period or an even earlier TMG version (for Windows).

VFI has the tools to deal with multiple image folders and exhibit trees and can relink all exhibits when relocation exhibit folders. The only requirement is that each image file has a unique name. VFI can't relink image files in an exhibit tree if images of the same name are identified by different folder names.

For example... one image tree. The path of the base folder must be entered into the location table and then you need to click the [Search in subfolders] button.

Jim

 

Hi Jim

thank you for your reply and help (as always).

What is VFI  ????

How can I delete this remnant from TMG5 and 6 looking in c:\Program Files\The Master Genealogist ? I think I had this prior to your fixing my data base a few months ago.

thanks

R.

Share this post


Link to post
Share on other sites

File / Maintenance / Validate File Integrity

If the exhibit record is erroneous, it can only be removed by editing the exhibit table like I did for you earlier.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×