Jump to content
LynnMcL

Report Screen Preview not working

Recommended Posts

After installing TMG 9.05 on a new computer, whenever I try to do a report and have the Report Destination set to Screen Preview, I don't get the report on the screen at all, but instead get a popup to tell me it exported it to an rtf file, in a folder under my AppData\Local\Temp folder. Has anyone else experiences this and now how to fix it? I can't find a setting that changes all screen previews to a file and I have the report output preference to be in a folder under the main TMG folder in My Documents and don't know what else to check. Is there some other setting I missed after the reinstallation? Thanks, Lynn

Share this post


Link to post
Share on other sites

The screen preview does generate a .RTF file in the temp folder. That's what you are looking at when you see the preview.

Run the installer again and select [Repair] and see if that resolves the issue.

Share this post


Link to post
Share on other sites

Running "repair" did not solve the problem, and lately others are complaining of the same issue. Also, possibly related, maybe not, is that when I have a report go to a file and I answer "yes" when it asks if I want the file to be opened for me, it doesn't actually open the file. It is strange that this started when I put TMG on a new computer - same Windows10 version and same TMG version as on the previous computer, but different results. 

Share this post


Link to post
Share on other sites
2 hours ago, LynnMcL said:

Running "repair" did not solve the problem, and lately others are complaining of the same issue. Also, possibly related, maybe not, is that when I have a report go to a file and I answer "yes" when it asks if I want the file to be opened for me, it doesn't actually open the file. It is strange that this started when I put TMG on a new computer - same Windows10 version and same TMG version as on the previous computer, but different results. 

I have the same problem as Lynn. Lynn, thanks for posting to this forum. John of SS suggested I look here. For Jim's sake, I'll summarize my actions to date.
 

Quote

 

I have uninstalled, removed all references/instances of TMG (Registry and folders)  and reinstalled TMG as Administrator but the problem remains.

I cannot find the solution to my problem in Terry's website. I also do not have a problem printing to a .pdf file.
It is only printing to screen where I have the problem.

Between my two TMG9.05 installations: Desktop w/Windows 7 and Laptop w/Windows 10, the Report Destination - Properties - Printer setup - settings are the same yet it is only in Win 10 that I cannot output to the screen.

 

I'd sure like to hear of a solution.

Tracey Milligan

Share this post


Link to post
Share on other sites

Campbell Stanford posted this on TMG-L:

Quote

I had similar problems after a new Windows 10 installation.  Report previews wouldn't work and word files went into a weird place and only as "rtf" files.

The answer was under Settings/Apps/Default Apps/Choose default applications by file type. The settings for ".doc" and ".docx" file type had disappeared. I replaced them with Word and all problems went away.

I am not sure why .doc and .docx settings would matter because TMG uses .rtf for its screen preview feature. Also, it seems odd to me that a default application would need to be set. However, it's worth a review of the settings. How are .doc, .docx, and .rtf set on your system?

Share this post


Link to post
Share on other sites

my Windows 10 .doc and .docx  defaults were set properly upon delivery of my laptop. So there is nothing to change there and thus not a solution.

Thx John for putting this here...

Tracey

Share this post


Link to post
Share on other sites

I'd check to make sure that .RTF also has a file association. I can see how the report output function requires a file association for any file type being output. I don't understand how the .DOC and .DOCX file associations would affect preview but a missing .RTF file association would most likely break preview. Also make sure that there is a default printer.

Share this post


Link to post
Share on other sites

I am having the same problem. Tried repair, checked file associations, printer is set up and works with other programs. This problem is only on my notebook computer and not on my desk top. It did work fine at one time. Wondering if one of the Windows 10 updates might be the issue. My notebook is a new Surface Pro 2018. Any other thoughts or suggestions?

Share this post


Link to post
Share on other sites

I'm up to date on Win10 on several computers and have no issue with screen preview.

Do you have a default printer assigned on the notebook?

Share this post


Link to post
Share on other sites

Yes default printer is set. No matter what printer I select including MS PDF it will only save an RTF file in a strange location. Also no matter what kind of report I select the same problem. Again it did work at one time on this machine until about two months ago.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×