Jump to content


Photo

File access denied

Temp C

  • Please log in to reply
32 replies to this topic

#1 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 07 July 2016 - 03:00 AM

My TMG version is 9.05.0000 UK. A few month ago I changes from Windows 7 to Window 10. The program worked well, until last week. Now, with almost every second click, I get the message: File access is denied. c:\users\kramer\appdata\local\temp\tmg6787606\x_event.cdx.   14   .UTILITY.DELETETMPDATABASE. If I select repeat or ignore I can go on in the normal way, but with one of the next clicks the message is on the screen again. Very disturbing.

I have run the repair routine of TMG 9 and cleaned my temp folder getting the message that a file containing 67487606 could not be found.

Where is the bug?

Peter Kramer

 



#2 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 07 July 2016 - 05:20 AM

We're trying to resolve a similar issue.

http://www.whollygen...ues/#entry67922

 

The pattern suggests that an external application is interfering with TMG and removing database files.

 

Are you using McAfee or AVG? Or any other anti-malware apps?



#3 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 07 July 2016 - 10:37 AM

I am using G Data Internet Security. And just in case, don't know if there is a causality: In the last few weeks TMG has been set back to trial mode quite a few times, I had to unlock it again.



#4 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 07 July 2016 - 12:13 PM

If you can open the project, you've lost no files.

 

Try reindexing since the error message referred to an index file (although it was a temporary index file in the temp folder).

 

Loss of the registration information is a 'feature' that was introduced by Windows 8.

 

Be sure to unlock running normally.

 

Then unlock running as administrator. Right-click on the TMG shortcut and select 'Run as administrator'. Unlock and exit TMG after unlocking. Now run TMG normally.



#5 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 07 July 2016 - 12:40 PM

I have run reindexing as well as optimising. And unlocked TMG as administrator. But after starting TMG again the reported problem remains.

 

You could try actually running TMG as administrator and see if that bypasses the problem.



#6 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 07 July 2016 - 02:02 PM

Over time, many TMG users have run into a temp folder 'file access denied' issue. If you search the forum, you'll find other topics on this issue (and maybe a solution). I have no idea for a solution for your problem.

 

You could try running TMG as administrator and see if that bypasses the problem.



#7 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 07 July 2016 - 02:40 PM

Thanks for your assistance anyway. You led me nearer to a possible solution.

Time for taking a rest, it's 0:30 am over here.



#8 scr

scr
  • Members
  • 4 posts

Posted 08 July 2016 - 05:43 AM

Peter,

I also have Win10 and also had got the 'trial period expired' today and entered my serial number again. I then imported a revized file and opened the program to ger the same message of can't access..... (I also have GData). I've had TMG9 on Win 10 since last September and other than putting in the serial number periodically it has been okay until now.

However, you may have done this as a workaround, I hit 'Ignore' and the data can be accessed [so far], but it would be nice to not have the error in the first place. You are not alone, but, obviously, you use the software more than I as I use it to make reports. 



#9 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 08 July 2016 - 08:07 AM

Since you are both running G Data, the first test to try is to exclude the TMG process in G data and see if that resolves the problem. (This should be tested running TMG normally, not as administrator.) 

 

If that doesn't help, I have another test to run that I'll describe if necessary.



#10 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 08 July 2016 - 01:35 PM

I have just finished a process stop - start - stop -start G-Data. THAT'S IT. If I exclude G-Data TMG is running without any disturbances. So I know how to stop the disturbing messages. But as I am using TMG very often for hours I will be unguarded for long periods.. What can I do? Try another program? I sent G-Data a notice if I could enter an exclusion for a memory-resident program (I suppose: not).



#11 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 08 July 2016 - 01:56 PM

G-Data should have an option to exclude selected processes. You exclude...

"C:\Program Files (x86)\The Master Genealogist v9\tmg9.exe"

 

This way, only TMG and the files that it uses are excluded from the real time protection. And doing this adds no security risk to your system.

 

Settings / General / AntiVirus / Real-time protection / Exceptions

(It's not clear whether you can exclude a process or only files.)

 

Most anti-virus software allows excluding processes (i.e., programs) so that all files used by the program are excluded.

 

In any event, you are on track to find the solution.



#12 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 08 July 2016 - 03:09 PM

Thanks for your detailed suggestion which I implemented in G-Data. But alas - even after a cold boot it didn't work.

 

Now I will wait for the answer of G-Data which I do not expect before Monday afternoon. I will keep you informed about the outcome.

 

By now it is 1 pm in Hamburg, I will be off.



#13 PeterKramer

PeterKramer
  • Members
  • 12 posts
  • Location:Hamburg, Germany

Posted 11 July 2016 - 09:40 AM

I got an advice from G Data which solved my problem. TMG is running as smooth as it should.

 

I had to follow the path suggested by Jim: Settings / General / AntiVirus / Real-time protection  but at that point select - the following is a translation from German, I don't know the exact terms used by G Data in their English version - "extended" (erweitert). In the new window then opening go to the top line: "mode" (Modus) and select "only check when running" (Nur beim Ausfuehren pruefen).

 

G Data confirmed that by this setting the security will not be reduced.



#14 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 11 July 2016 - 12:56 PM

Settings / General / AntiVirus / Real-time protection / Advanced / Mode / Only check when running



#15 Redleg21

Redleg21
  • Members
  • 7 posts

Posted 17 July 2016 - 02:03 PM

I am not sure if this is related but if you had to reinstall TMG 9 you may be trying to run a project that was made on a newer version. For example The basic disk for TMG 9 is 9.01. If the Project was made on TMG 9.05 you will get a file access denied message.

 

I resolved the issue by making a GEDCOM installing it to another program (Ancestry 2011) Then made a GEDCOM in ancestry and installed in into TMG 9.01. When you install it you may have to use Advanced Import if you have any custom tags.

 

My project which was made in TMG 9.05 now works fine in TMG 9.01.

 

I have not been able to find a download to TMG 9.05.



#16 Michael Hannah

Michael Hannah
  • Moderators
  • 2,739 posts
  • Gender:Male
  • Location:Los Ranchos, New Mexico, USA
  • Interests:Genealogy, Computers

Posted 17 July 2016 - 03:00 PM

This is a separate pinned topic in this forum.  See

TMG9 - Final installers (v9.-5)


Michael
See my book on how I customize TMG My Way.
My website.

#17 Jim Byram

Jim Byram
  • Moderators
  • 7,350 posts
  • Gender:Male
  • Location:Framingham, MA

Posted 02 October 2016 - 10:57 AM

Ray Porter found an issue similar to Peter's with BitDefender Total Security and the issue was resolved by excluding TMG in BitDefender.



#18 Hicere

Hicere
  • Members
  • 3 posts

Posted 11 October 2016 - 01:20 AM

Hi there, I also have that problem. Thanks for sharing.



#19 Nicholas F. Dann

Nicholas F. Dann
  • Members
  • 5 posts
  • Gender:Male
  • Location:Gig Harbor, Washington

Posted 26 November 2016 - 11:39 AM

Help! I have TMG 9.05 which was running fine via Parallels Windows XP VM. A recent MAC OS update caused my access to Windows XP to be null and void - and apparently my TMG was still running when this happened. XP still shows up in Parallels, but delivers the infamous MS blue screen of death. So I bought W10, and reinstalled TMG. Starts up fine, but now I cannot get my archived pjc file to open - message says it's still in use. Yeah, in my XP VM which I can't access! How can I recover nearly 25 years worth of work?



#20 Redleg21

Redleg21
  • Members
  • 7 posts

Posted 26 November 2016 - 12:03 PM

Nicholas, when you reinstalled TMG you installed 9.01.  You then tried to run your 9.05 file on the 9.01. The problem is you need the 9.05 upgrade which was only downloaded over the internet. I resolved the problem in my post above 17 Jul 2016.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users