Jump to content

All Activity

This stream auto-updates     

  1. Today
  2. TMG Performance since last windows update

    A TMG project consists of more than two dozen files, of which the .pjc file is only one and has very little actual data in it. No program other than TMG should be touching any of these project files while that project is open in a running TMG program. Corruption of any one of these files can potentially corrupt the usability of the entire project. If the backup program is configured to not attempt to copy any of the project files until TMG is closed, then as I said before, that should be okay.
  3. Yesterday
  4. it doesn't attempt to copy the pjc until TMG closed. What files are you particularly concerned about?
  5. TMG Performance since last windows update

    Dave, I am concerned about your comment about backing up TMG files "on the fly". If you have some program backing up TMG files while TMG is running this will some day be a problem. Such a backup scenario is the major cause of corruption of TMG projects. However, if the backup does not occur while TMG is running but you wait until you exit TMG and then invoke the program to backup TMG files to the cloud, then that should be okay.
  6. Yes, I had misinterpreted the message/functionality of the check box. John got me thinking on the rationale of not backing up images with TMG internal backup - "can cause the SQZ file to exceed the maximum size of a ZIP file." Using 7-zip I zipped up a copy of the images directory and the compressed file is 10.0 GB (10,756,108,301 bytes to be accurate ) which is way bigger than a zip file can manage and I guess foxpro db are limited to 2Gb So the error is more a file limitation than an error as such. & as far as being related to failure to import into Family Historian a complete red herring. The uncompressed directory is 11.2 GB (12,026,769,408 bytes) so indeed the compression doesn't achieve very much at all.
  7. The exhibit table (_I.dbf) is always backed up when a project is backed up. The popup was just telling you how many exhibit files would be added to the backup when the external exhibits option is selected. The count is based on how many links were found in the exhibit table. C0000005 errors are difficult to diagnose; however, in this case, I believe that the error is coming from an issue with one of the exhibit files.
  8. Hi John yes - I don't really use internal TMG backups at all, it was just that this seemed to be identifying an issue that may (or may not) be related to an attempt to import into Family Historian to have a look at that. I have read over the last few days a several pieces of advice which concurs with you. I do have separate back up regimes. (ISP Cloud solution & SmartSync Pro for local processes.) In step 3 of the backup process, under project items > Project data files you see "external exhibits", hovering over that it tells you it has found x links to external exhibits and specifies a database project_I_.dbf. I had presumed that this was backing up the links not the image itself. But as I do not actively use the process I haven't really looked at it in any detail. However if it is backing up the image then I agree this is totally pointless as they are external to the project and are backed up as part of my data resiliency program. But having found this OLE error am now a bit obsessed with identifying the object in question. I did look at inserting OLE objects some time ago but can't remember why or where. I don't think there is anything that would identify the object in your handy utility and I recreated a second site site (local, I don't have a published version) and that worked fine I also enabled thumbnails but the db they are stored in went over size limitation and broke. Replaced it with backup copy and reduced the thumbnail size to just 50. Again this ran OK so in both cases each and every exhibit would have been touched. I was hoping one or both would identify the problem object. The performance issue opening the exhibits window seems better now. I had used performance manager to look at running process, and as this had been going over several days possibly ever since the last W10 update I was concerned something more fundamental was at work. Nvidia graphics driver updated recently as well. However all seems well now. I can look at Family Historian using another project, I just have this OLE error nagging at me. Dave
  9. Last week
  10. TMG Performance since last windows update

    Dave, I recommend that you NOT include external exhibits in your TMG backups. You should have a separate backup regimen for those digital assets, perhaps integrated with backups for other images that are not exhibits. Including exhibits in a TMG backup increases the size of the backup SQZ file and increases the amount of time that TMG takes to write the backup file. Meanwhile, the exhibits don't change very often. Lastly, if you have a lot of exhibits, the image data---which doesn't compress much--can cause the SQZ file to exceed the maximum size of a ZIP file. (SQZ files are ZIP files in disguise.) TMG always performs reasonably well for me. The only operations that are slow enough to annoy me are (A) opening the Master Place List, which is glacial, (B) importing GEDCOM files (which I do rarely as part of testing), and (C) exporting GEDCOM files (which I also do only rarely). The only other performance issue I have seen is when there was a "ghost" instance of TMG running that was using a lot of CPU. That was affecting all the other programs running on my PC, but had a particularly nasty impact on TMG, which was so sluggish it was almost unusable. I do not know what caused it. I only remember it happening once. I killed the ghost TMG process after I noticed it, and that solved the problem. Users who don't have the skills to check what processes are running and manipulate them can solve the problem by rebooting. John
  11. Hi Jim, Diane, Oddly seems to be better today. Carried out routine maintenance (again) which included this time a backup of the project. I rarely do an internal TMG back up of the project as its is backed up on the fly to cloud, on PC shutdown to two external devices and once a week to a back up PC (which in turn is backed up to external device prior to this) so effectively I have a current backup, daily back ups, weekly backup and a two week old back up. I may be a little paranoid about data loss. However there is some problem with the TMG Backup when you include the links to external files - OLE Exception error c0000005 or c00000fd which cause the backup to fail. This does not impact normal bau operation of TMG. This problem is also present with the project daily backups, I haven't checked older. Dave
  12. TMG Performance since last windows update

    I've been using mine quite a bit the last few weeks with no problems, but I do use exhibits.
  13. Hi Jim, Thanks for response. Using OS Name Microsoft Windows 10 Pro Version 10.0.17763 Build 17763 Processor Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s) Installed Physical Memory (RAM) 32.0 GB Total Physical Memory 31.9 GB Available Physical Memory 25.5 GB Total Virtual Memory 36.7 GB Available Virtual Memory 28.8 GB Page File Space 4.75 GB Name NVIDIA GeForce GTX 1660 Adapter RAM (1,048,576) bytes Driver Version 26.21.14.3064 Resolution 3440 x 1440 x 59 hertz Bits/Pixel 32 Has been fine on this PC since project moved to it some years ago Just in the last few days its been really slow when opening the Media page. And having noticed that you then start to realise everything else is also a bit slow. Main project has just under 10K people & the external exhibit directory is some 11Gb containing 13,711 files in 481 sub directories. Have tried tiny projects and they suffer the same issue, but they are pointing at the same exhibit directory which may or may not be relevant. Dave
  14. I've had no performance issues with TMG in years. I'm currently running Win10 1809 with last Tuesday's cumulative update (17763.503).
  15. Hi all, Just recently TMG performance has bombed, most noticeably opening exhibits but is actually quite slow at redrawing any of the gui. No changes have been made, all I can link this with is last Windows (10) update. Have gone through normal file maintenance. Tested on a very small project & the problem is the same as on my main large project. Anybody else seen this? - if anybody else is still using TMG............ Dave
  16. Earlier
  17. Ginny, I don't know what would cause the instability that you describe. The optimize byte count is mainly updating the index files and is of no consequence. I'd like to examine your project. You can contact me by email by clicking on the link below... Jim Byram
  18. I need help with stabilizing TMG V9. For a few weeks I began having larger & larger optimize results although few changes had been made between optimizations. Then after working on several bios in a single family, I could not access any tags in TMG and could not access tags in a backup made at that point. (I note here the Filtered header is on above my tags but the controls have long been grayed out with no obvious impact.) I went to the previous backup; file integrity said it fixed 2,xxx errors. I did a number of restores & even reloaded the SW thinking the Filtered issue might be a cause but TMG locked up each time. A Users Group member restored my backup to his computer, turned off Filtered, I restored that version, filtered immediately came back on with no control available to it turn off, and that restored version worked for a couple of hours, but also with large optimize results and then TMG locked up and I cannot access tags in that backup. I have now gone back to an even earlier backup and restored that, did all 3 maintenances with no issues, changed the parents for 3 children, and optimize shows 653,566 bytes saved, so I know this is going to lock up again soon. File integrity shows no issues. What do I do next? Ginny
  19. Backup fails

    Glad that you got things fixed. This error comes from the ZIP file component used by TMG. It typically happens when the backup is written to an external drive. Why you got the error and why your fix worked is a mystery. The error is not usually project-related. I didn't suggest the ZIP file as a routine backup although note that the TMG backup is just a ZIP file and can be duplicated manually. My point was to suggest that there are alternative methods to protect your data.
  20. Backup fails

    Since I back up every night, this would take more space and time that the work I did do. I extracted records last edited since 6 May to a new project; deleted the project; restored the project from my laptop to a new folder (thanks to your advice); and merged the projects, merged the 28 people, merged sources, and now have a project that backs up. It only took about 90 minutes.
  21. Backup fails

    There is no need to re-enter the data. You can always make a backup by making a .ZIP file of a project folder, naming it appropriately and storing it in a safe location. You can delete the .CDX files from the .ZIP file to make it smaller. This is a good reason to store each project in its own folder.
  22. Backup fails

    Jim, I do usually use the backup folder. This project will not backup, regardless of the destination It originated from a .sqz on my laptop, and that was backed up directly to a thumb drive. I entered data for about four hours taday, before discovering the problem. If you cannot think of anything else, I will do a standard backup on the laptop, copy it to this computer via a thumbdrive, and reenter. So if you have any ideas, I'll try them first. John MayBee
  23. Backup fails

    Try backing up to the backups folder in the TMG user tree. Typically... C:\Users\(user account name)\Documents\The Master Genealogist v9\Backups
  24. Backup fails

    When I try to backup my project, I get the message: “Input file read failure - this error occurs when a read operation is performed on a ZIP file that is locked or restricted by another process” I ran validate file integrity - no problem found I’ve rebooted the computer - no help I moved all backups to another drive - no help I copied project to a new name - no help, still wouldn’t backup I opened a different project, it backed up properly. So my problem seems to be only with this one project Anybody have any ideas?
  25. Error in LOW report

    There is another speed bump in this workaround - the limitation in the number of rows in the Excel v. 5 output. A list of all witnesses is limited to 65,536 rows, so if the database is large enough to trigger the original "too large" error message, the number of witnesses is probably greater than the 65,536 rows. This limitation does not seem to exist in CSV output, so that output should be used in these "List of All Witnesses" reports. Any Excel version, 2007 and later, opens this report with no problems. Michael and Jim, do you find the same thing? Sue Johnston
  26. Thanks Jim, you're right. My Windows 10 language was apparently set to English (Netherlands). I changed it to English (United States) and it's looking fine now.
  27. Strange characters in list windows

    Looks like some sort of language issue. Symbols are not displaying correctly. What's the Windows language? What's the TMG language? File / Language
  28. Hi, I just got a new laptop with Windows 10 1809 on it. After installing TMG 9.05, and opening the sample project, I got strange characters on the list windows (see screenshot) This is just the plain unmodified install. I didn't restore settings from a backup yet. I already tried repairing the install. Also a complete uninstall (deleting the directories under ProgramData and AppData\Roaming). But this didn't make a difference. Also changing the font for the lists from Tahoma to some other font doesn't solve it. Any ideas what's going on? Thanks, Arjan
  29. Error in LOW report

    Thanks, Susan, I did understand that the workaround was unfiltered spreadsheet output, i.e. all witnesses. However, I was unaware (or had forgotten) that the LOW output columns cannot show a non-standard Flag. Yes, please update me if you discover any other "speed bumps". See the two new entries in my Bugs document starting here: https://www.mjh-nm.net/BUGS.HTML#B103 Let me know if you have suggestions to improve the wording.
  1. Load more activity
×